summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-ti/recipes-arago/ipc
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-bsp/meta-ti/recipes-arago/ipc')
-rw-r--r--meta-agl-bsp/meta-ti/recipes-arago/ipc/patches/add-dependency-of-pthreads.patch13
-rw-r--r--meta-agl-bsp/meta-ti/recipes-arago/ipc/ti-ipc_git.bbappend7
2 files changed, 20 insertions, 0 deletions
diff --git a/meta-agl-bsp/meta-ti/recipes-arago/ipc/patches/add-dependency-of-pthreads.patch b/meta-agl-bsp/meta-ti/recipes-arago/ipc/patches/add-dependency-of-pthreads.patch
new file mode 100644
index 000000000..649eef5b1
--- /dev/null
+++ b/meta-agl-bsp/meta-ti/recipes-arago/ipc/patches/add-dependency-of-pthreads.patch
@@ -0,0 +1,13 @@
+diff --git a/linux/src/transport/Makefile.am b/linux/src/transport/Makefile.am
+index 32f0046..b4d3078 100644
+--- a/linux/src/transport/Makefile.am
++++ b/linux/src/transport/Makefile.am
+@@ -32,7 +32,7 @@
+ ##
+
+ # additional include paths necessary to compile the library
+-AM_CFLAGS = -I$(top_srcdir)/hlos_common/include -D_GNU_SOURCE -Wall
++AM_CFLAGS = -I$(top_srcdir)/hlos_common/include -D_GNU_SOURCE -Wall -pthread
+
+ if KERNEL_INSTALL_DIR
+ AM_CFLAGS += -I$(KERNEL_INSTALL_DIR)/include/generated/uapi
diff --git a/meta-agl-bsp/meta-ti/recipes-arago/ipc/ti-ipc_git.bbappend b/meta-agl-bsp/meta-ti/recipes-arago/ipc/ti-ipc_git.bbappend
new file mode 100644
index 000000000..ca5cdef42
--- /dev/null
+++ b/meta-agl-bsp/meta-ti/recipes-arago/ipc/ti-ipc_git.bbappend
@@ -0,0 +1,7 @@
+#inherit append-code-change
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/patches/:"
+
+SRC_URI_append = " \
+ file://add-dependency-of-pthreads.patch \
+"