summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-ti/recipes-arago
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-bsp/meta-ti/recipes-arago')
-rw-r--r--meta-agl-bsp/meta-ti/recipes-arago/gstreamer/gstreamer1.0-plugins-bad_%.bbappend13
-rw-r--r--meta-agl-bsp/meta-ti/recipes-arago/ipumm-fw/ipumm-fw_3.00.13.00.bb2
-rw-r--r--meta-agl-bsp/meta-ti/recipes-arago/weston/weston_%.bbappend7
3 files changed, 16 insertions, 6 deletions
diff --git a/meta-agl-bsp/meta-ti/recipes-arago/gstreamer/gstreamer1.0-plugins-bad_%.bbappend b/meta-agl-bsp/meta-ti/recipes-arago/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
index 53cd834aa..f1fd52d35 100644
--- a/meta-agl-bsp/meta-ti/recipes-arago/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
+++ b/meta-agl-bsp/meta-ti/recipes-arago/gstreamer/gstreamer1.0-plugins-bad_%.bbappend
@@ -19,8 +19,12 @@ DEPENDS_append_ti33x = " \
libdrm \
"
-SRC_URI_append_ti43x = " \
+############## F I X M E #####################
+# FIXME pyro
+SRC_URI_append = " \
file://0001-gstdrmallocator-Add-DRM-allocator-support.patch \
+"
+DISABLED_SRC_URI_append_ti43x = " \
file://0002-parsers-Pick-previos-bug-fixes-on-different-parsers.patch \
file://0003-gstkmssink-Add-support-for-KMS-based-sink.patch \
file://0004-gstwaylandsink-Add-DRM-support-on-waylandsink.patch \
@@ -29,11 +33,13 @@ SRC_URI_append_ti43x = " \
file://0001-gstwaylandsink-add-input-format-I420-support.patch \
"
-SRC_URI_append_ti33x = " \
+# FIXME pyro
+DISABLED_SRC_URI_append_ti33x = " \
file://0001-gstwaylandsink-Add-mouse-drag-and-drop-support.patch \
"
-SRC_URI_append_omap-a15 = " \
+# FIXME pyro
+DISABLED_SRC_URI_append_omap-a15 = " \
file://0001-gstdrmallocator-Add-DRM-allocator-support.patch \
file://0002-parsers-Pick-previos-bug-fixes-on-different-parsers.patch \
file://0003-gstkmssink-Add-support-for-KMS-based-sink.patch \
@@ -43,6 +49,7 @@ SRC_URI_append_omap-a15 = " \
file://0001-gstwaylandsink-add-input-format-I420-support.patch \
file://0005-gstwaylandsink-Implement-callbacks-for-version-5-of-.patch \
"
+################ F I X M E ####################
PACKAGE_ARCH = "${MACHINE_ARCH}"
diff --git a/meta-agl-bsp/meta-ti/recipes-arago/ipumm-fw/ipumm-fw_3.00.13.00.bb b/meta-agl-bsp/meta-ti/recipes-arago/ipumm-fw/ipumm-fw_3.00.13.00.bb
index 4fdfd7ddb..a9653f4d3 100644
--- a/meta-agl-bsp/meta-ti/recipes-arago/ipumm-fw/ipumm-fw_3.00.13.00.bb
+++ b/meta-agl-bsp/meta-ti/recipes-arago/ipumm-fw/ipumm-fw_3.00.13.00.bb
@@ -1,5 +1,5 @@
python __anonymous() {
- features = bb.data.getVar("MACHINE_FEATURES", d, 1)
+ features = d.getVar("MACHINE_FEATURES", 1)
if not features:
return
if "mmip" not in features:
diff --git a/meta-agl-bsp/meta-ti/recipes-arago/weston/weston_%.bbappend b/meta-agl-bsp/meta-ti/recipes-arago/weston/weston_%.bbappend
index ed20c7420..8704908f2 100644
--- a/meta-agl-bsp/meta-ti/recipes-arago/weston/weston_%.bbappend
+++ b/meta-agl-bsp/meta-ti/recipes-arago/weston/weston_%.bbappend
@@ -8,8 +8,9 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
RDEPENDS_${PN} += "weston-conf"
-
-SRC_URI += " \
+####################### F I X M E ##########################
+# FIXME pyro
+DISABLED_SRC_URI += " \
file://0001-udev-seat-restrict-udev-enumeration-to-card0.patch \
file://0001-Add-soc-performance-monitor-utilites.patch \
file://0002-Weston-Allow-visual_id-to-be-0.patch \
@@ -18,5 +19,7 @@ SRC_URI += " \
file://0001-compositor-drm-fix-hotplug-weston-termination-proble.patch \
file://0001-compositor-drm-support-RGB565-with-pixman-renderer.patch \
"
+####################### F I X M E ##########################
+
RDEPENDS_${PN}_remove = "weston-conf"