summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/recipes-graphics
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-bsp/recipes-graphics')
-rw-r--r--meta-agl-bsp/recipes-graphics/mesa/mesa/0001-Use-llvm_prefix-variable-directly.patch25
-rw-r--r--meta-agl-bsp/recipes-graphics/mesa/mesa_%.bbappend (renamed from meta-agl-bsp/recipes-graphics/mesa/mesa_12.%.bbappend)4
2 files changed, 29 insertions, 0 deletions
diff --git a/meta-agl-bsp/recipes-graphics/mesa/mesa/0001-Use-llvm_prefix-variable-directly.patch b/meta-agl-bsp/recipes-graphics/mesa/mesa/0001-Use-llvm_prefix-variable-directly.patch
new file mode 100644
index 000000000..4f1905492
--- /dev/null
+++ b/meta-agl-bsp/recipes-graphics/mesa/mesa/0001-Use-llvm_prefix-variable-directly.patch
@@ -0,0 +1,25 @@
+From 0b316ee830765eb1d68cdece5fd4c991e9fba96c Mon Sep 17 00:00:00 2001
+From: Changhyeok Bae <changhyeok.bae@gmail.com>
+Date: Sat, 8 Jul 2017 15:22:09 +0900
+Subject: [PATCH] Use $llvm_prefix variable directly
+
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index ac110e8..d094ca6 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -896,7 +896,7 @@ fi
+
+ if test -z "$LLVM_CONFIG"; then
+ if test -n "$llvm_prefix"; then
+- AC_PATH_TOOL([LLVM_CONFIG], [llvm-config], [no], ["$llvm_prefix/bin"])
++ AC_PATH_TOOL([LLVM_CONFIG], [llvm-config], [no], ["$llvm_prefix"])
+ else
+ AC_PATH_TOOL([LLVM_CONFIG], [llvm-config], [no])
+ fi
+--
+1.9.1
+
diff --git a/meta-agl-bsp/recipes-graphics/mesa/mesa_12.%.bbappend b/meta-agl-bsp/recipes-graphics/mesa/mesa_%.bbappend
index 49e527707..13273792b 100644
--- a/meta-agl-bsp/recipes-graphics/mesa/mesa_12.%.bbappend
+++ b/meta-agl-bsp/recipes-graphics/mesa/mesa_%.bbappend
@@ -1,3 +1,7 @@
+FILESEXTRAPATHS_prepend_qemux86-64 := "${THISDIR}/${BPN}:"
+SRC_URI_append_qemux86-64 = " file://0001-Use-llvm_prefix-variable-directly.patch"
+EXTRA_OECONF_qemux86-64 = "--enable-shared-glapi --with-llvm-prefix=${STAGING_BINDIR_CROSS}"
+
# The gallium-llvm is recommended as software 3D graphics renderer
GALLIUM_LLVM = "gallium-llvm"
PACKAGECONFIG_append_qemux86 = " gallium ${GALLIUM_LLVM}"