summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-bsp')
-rw-r--r--meta-agl-bsp/meta-ti/recipes-bsp/u-boot/files/0001-mmc-disable-the-mmc-clock-during-power-off.patch29
-rw-r--r--meta-agl-bsp/meta-ti/recipes-bsp/u-boot/u-boot-ti-staging_%.bbappend3
2 files changed, 31 insertions, 1 deletions
diff --git a/meta-agl-bsp/meta-ti/recipes-bsp/u-boot/files/0001-mmc-disable-the-mmc-clock-during-power-off.patch b/meta-agl-bsp/meta-ti/recipes-bsp/u-boot/files/0001-mmc-disable-the-mmc-clock-during-power-off.patch
new file mode 100644
index 000000000..3be8dc744
--- /dev/null
+++ b/meta-agl-bsp/meta-ti/recipes-bsp/u-boot/files/0001-mmc-disable-the-mmc-clock-during-power-off.patch
@@ -0,0 +1,29 @@
+From 96d42df4e7cb700bde4bdf5106cfd2753749c4e7 Mon Sep 17 00:00:00 2001
+From: Kishon Vijay Abraham I <kishon@ti.com>
+Date: Fri, 11 Nov 2016 19:59:22 +0530
+Subject: [PATCH] mmc: disable the mmc clock during power off
+
+There is no point in having the mmc clock enabled during
+power off. Disable the mmc clock. This is similar to how it's
+programmed in Linux Kernel.
+
+Signed-off-by: Kishon Vijay Abraham I <kishon@ti.com>
+---
+ drivers/mmc/mmc.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/drivers/mmc/mmc.c b/drivers/mmc/mmc.c
+index c929a1e..84515a7 100644
+--- a/drivers/mmc/mmc.c
++++ b/drivers/mmc/mmc.c
+@@ -2058,6 +2058,7 @@ static void mmc_power_off(struct mmc *mmc)
+ {
+ mmc_set_signal_voltage(mmc, 0);
+ mmc_set_vdd(mmc, false);
++ mmc_set_clock(mmc, 1, true);
+ }
+
+ static void mmc_power_cycle(struct mmc *mmc)
+--
+1.9.1
+
diff --git a/meta-agl-bsp/meta-ti/recipes-bsp/u-boot/u-boot-ti-staging_%.bbappend b/meta-agl-bsp/meta-ti/recipes-bsp/u-boot/u-boot-ti-staging_%.bbappend
index 77b84f990..8f4402bac 100644
--- a/meta-agl-bsp/meta-ti/recipes-bsp/u-boot/u-boot-ti-staging_%.bbappend
+++ b/meta-agl-bsp/meta-ti/recipes-bsp/u-boot/u-boot-ti-staging_%.bbappend
@@ -1,12 +1,13 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
-SRCREV = "${AUTOREV}"
+SRCREV = "7e76f5e6781205bbdf4ec53aa6671b30856a33e7"
BRANCH = "p-ti-u-boot-2016.05"
SRC_URI = "git://git.omapzoom.org/repo/u-boot.git;protocol=git;branch=${BRANCH}"
# This applies to the JACINTO 6 vayu board ... essentially it is dra7_evm.
SRC_URI_vayu += "file://fix_builderror_gcc5.patch"
SRC_URI += " file://${UBOOT_ENV_BINARY}"
+SRC_URI += " file://0001-mmc-disable-the-mmc-clock-during-power-off.patch"
UBOOT_ENV = "uEnv"