summaryrefslogtreecommitdiffstats
path: root/meta-agl-core-test/recipes-test/freetype/files
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-core-test/recipes-test/freetype/files')
-rw-r--r--meta-agl-core-test/recipes-test/freetype/files/0001-Makefile-dont-build-gfx-demos.patch41
-rw-r--r--meta-agl-core-test/recipes-test/freetype/files/0001-ft2demos-Makefile-Do-not-hardcode-libtool-path.patch25
2 files changed, 34 insertions, 32 deletions
diff --git a/meta-agl-core-test/recipes-test/freetype/files/0001-Makefile-dont-build-gfx-demos.patch b/meta-agl-core-test/recipes-test/freetype/files/0001-Makefile-dont-build-gfx-demos.patch
index 4d0d09aea..bd9b4c064 100644
--- a/meta-agl-core-test/recipes-test/freetype/files/0001-Makefile-dont-build-gfx-demos.patch
+++ b/meta-agl-core-test/recipes-test/freetype/files/0001-Makefile-dont-build-gfx-demos.patch
@@ -1,17 +1,16 @@
-diff -ur ft2demos-2.9.1.orig/Makefile ft2demos-2.9.1/Makefile
---- ft2demos-2.9.1.orig/Makefile 2018-04-22 05:41:50.000000000 -0400
-+++ ft2demos-2.9.1/Makefile 2019-02-18 23:28:59.794678736 -0500
-@@ -163,7 +163,8 @@
-
- ifeq ($(PLATFORM),unix)
- CC = $(CCraw)
-- LINK_CMD = $(subst /,$(SEP),$(OBJ_BUILD)/libtool) \
-+ LIBTOOL = $(OBJ_BUILD)/libtool
-+ LINK_CMD = $(subst /,$(SEP),$(LIBTOOL)) \
- --mode=link $(CC) \
- $(subst /,$(COMPILER_SEP),$(LDFLAGS))
- LINK_LIBS = $(subst /,$(COMPILER_SEP),$(FTLIB) $(EFENCE)) $(LIB_CLOCK_GETTIME)
-@@ -289,12 +290,12 @@
+Do not build graphics tests
+
+Upstream-Status: Inappropriate [disable feature]
+Signed-off-by: Scott Murray <scott.murray@konsulko.com>
+---
+ Makefile | 14 +++++++-------
+ 1 file changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 8bb8666..95e5e45 100644
+--- a/Makefile
++++ b/Makefile
+@@ -297,13 +297,13 @@ else
ttdebug
# Comment out the next line if you don't have a graphics subsystem.
@@ -19,14 +18,16 @@ diff -ur ft2demos-2.9.1.orig/Makefile ft2demos-2.9.1/Makefile
- ftgamma \
- ftgrid \
- ftmulti \
+- ftsdf \
- ftstring \
- ftview
-+ # EXES += ftdiff \
-+ # ftgamma \
-+ # ftgrid \
-+ # ftmulti \
-+ # ftstring \
-+ # ftview
++ #EXES += ftdiff \
++ # ftgamma \
++ # ftgrid \
++ # ftmulti \
++ # ftsdf \
++ # ftstring \
++ # ftview
# ftvalid requires ftgxval.c and ftotval.c
#
diff --git a/meta-agl-core-test/recipes-test/freetype/files/0001-ft2demos-Makefile-Do-not-hardcode-libtool-path.patch b/meta-agl-core-test/recipes-test/freetype/files/0001-ft2demos-Makefile-Do-not-hardcode-libtool-path.patch
index 7803ad7e0..879b80506 100644
--- a/meta-agl-core-test/recipes-test/freetype/files/0001-ft2demos-Makefile-Do-not-hardcode-libtool-path.patch
+++ b/meta-agl-core-test/recipes-test/freetype/files/0001-ft2demos-Makefile-Do-not-hardcode-libtool-path.patch
@@ -8,23 +8,24 @@ Content-Transfer-Encoding: 8bit
It is already known and imported through config.mk.
+Upstream-Status: Inappropriate [embedded specific]
Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
+[Updated for freetype 2.10.4]
+Signed-off-by: Scott Murray <scott.murray@konsulko.com>
---
- Makefile | 1 -
- 1 file changed, 1 deletion(-)
+ Makefile | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/Makefile b/Makefile
-index a5d34bd..254aad4 100644
+index 851c4f7..c537983 100644
--- a/Makefile
+++ b/Makefile
-@@ -153,7 +153,6 @@ else
+@@ -165,7 +165,7 @@ else
ifeq ($(PLATFORM),unix)
- CC = $(CCraw)
-- LIBTOOL = $(OBJ_BUILD)/libtool
- LINK_CMD = $(subst /,$(SEP),$(LIBTOOL)) \
- --mode=link $(CC) \
- $(subst /,$(COMPILER_SEP),$(LDFLAGS))
---
-2.1.4
-
+ override CC = $(CCraw)
+- LINK_CMD = $(subst /,$(SEP),$(OBJ_BUILD)/libtool) \
++ LINK_CMD = $(subst /,$(SEP),$(LIBTOOL)) \
+ --mode=link $(CC) \
+ $(subst /,$(COMPILER_SEP),$(LDFLAGS))
+ LINK_LIBS = $(subst /,$(COMPILER_SEP),$(FTLIB) $(EFENCE)) $(LIB_CLOCK_GETTIME)