summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-core/conf
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-profile-core/conf')
-rw-r--r--meta-agl-profile-core/conf/include/agl-devel.inc15
-rw-r--r--meta-agl-profile-core/conf/include/agl-gplv2.inc8
-rw-r--r--meta-agl-profile-core/conf/include/base-agl.inc19
-rw-r--r--meta-agl-profile-core/conf/layer.conf10
4 files changed, 52 insertions, 0 deletions
diff --git a/meta-agl-profile-core/conf/include/agl-devel.inc b/meta-agl-profile-core/conf/include/agl-devel.inc
new file mode 100644
index 000000000..705b1739a
--- /dev/null
+++ b/meta-agl-profile-core/conf/include/agl-devel.inc
@@ -0,0 +1,15 @@
+IMAGE_FEATURES =+ "debug-tweaks eclipse-debug tools-debug tools-profile"
+
+#IMAGE_INSTALL_append = " \
+# packagegroup-agl-core-devel \
+#"
+
+IMAGE_INSTALL_append = "${@bb.utils.contains('IMAGE_FSTYPES', 'wic.vmdk', ' open-vm-tools vboxguestdrivers', '', d)}"
+
+# disable install of debug files in SDK
+# initial value: SDKIMAGE_FEATURES="dev-pkgs dbg-pkgs staticdev-pkgs"
+SDKIMAGE_FEATURES="dev-pkgs"
+
+# allows insertion of code or items specific to developement
+OVERRIDES .= ":agl-devel"
+DISTRO_FEATURES_append = " agl-devel"
diff --git a/meta-agl-profile-core/conf/include/agl-gplv2.inc b/meta-agl-profile-core/conf/include/agl-gplv2.inc
new file mode 100644
index 000000000..fc9a4072b
--- /dev/null
+++ b/meta-agl-profile-core/conf/include/agl-gplv2.inc
@@ -0,0 +1,8 @@
+# GPLv3 Compliance
+PREFERRED_VERSION_bash = "3.2.%"
+PREFERRED_VERSION_gawk = "3.1.%"
+PREFERRED_VERSION_gdbm = "1.8.%"
+PREFERRED_VERSION_gnupg = "1.4.7"
+PREFERRED_VERSION_gnutls = "3.3.%"
+PREFERRED_VERSION_mc = "4.7.5.%"
+PREFERRED_VERSION_readline = "5.2"
diff --git a/meta-agl-profile-core/conf/include/base-agl.inc b/meta-agl-profile-core/conf/include/base-agl.inc
new file mode 100644
index 000000000..a332c08a4
--- /dev/null
+++ b/meta-agl-profile-core/conf/include/base-agl.inc
@@ -0,0 +1,19 @@
+# AGL includes all kernel modules here for ease-of-use during development.
+# Comment this out to be able to select the kernel modules yourself.
+IMAGE_INSTALL_append = " kernel-modules"
+
+# Likewise as we included all kernel modules by default in the filesystem,
+# we do not need a separate tarball stored.
+# Comment this out to receive the separate modules tarball again.
+MODULE_TARBALL_DEPLOY ?= "0"
+
+# Comment out below if want to use QtWebkit
+PACKAGECONFIG_remove_pn-qtquick1 = "webkit"
+
+
+ASSUME_PROVIDED_remove = "tar-native"
+
+# Use static IDs to enable full-filesystem updates
+USERADDEXTENSION = "useradd-staticids"
+USERADD_ERROR_DYNAMIC = "error"
+
diff --git a/meta-agl-profile-core/conf/layer.conf b/meta-agl-profile-core/conf/layer.conf
new file mode 100644
index 000000000..83c5555bc
--- /dev/null
+++ b/meta-agl-profile-core/conf/layer.conf
@@ -0,0 +1,10 @@
+# We have a conf and classes directory, add to BBPATH
+BBPATH =. "${LAYERDIR}:"
+
+# We have recipes-* directories, add to BBFILES
+BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
+ ${LAYERDIR}/recipes-*/*/*.bbappend"
+
+BBFILE_COLLECTIONS += "aglprofilecore"
+BBFILE_PATTERN_aglprofilecore = "^${LAYERDIR}/"
+BBFILE_PRIORITY_aglprofilecore = "80"