summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping-ci_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping-ci_1.0.bb')
-rw-r--r--meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping-ci_1.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping-ci_1.0.bb b/meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping-ci_1.0.bb
new file mode 100644
index 000000000..cbba57308
--- /dev/null
+++ b/meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping-ci_1.0.bb
@@ -0,0 +1,18 @@
+SUMMARY = "AGL demo device mapping configuration file"
+DESCRIPTION = "This provides a default dev-mapping.conf file \
+ that defines mapping between kernel device and logical name \
+ used in the low-can binding for the AGL CI setup."
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI += "file://dev-mapping.conf.ci"
+
+inherit allarch
+
+do_install() {
+ install -d ${D}${sysconfdir}
+ install -m 0644 ${WORKDIR}/dev-mapping.conf.ci ${D}${sysconfdir}/dev-mapping.conf
+}
+
+RPROVIDES_${PN} = "virtual/low-can-dev-mapping"