summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping_0.1.bb')
-rw-r--r--meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping_0.1.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping_0.1.bb b/meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping_0.1.bb
new file mode 100644
index 000000000..befb5443f
--- /dev/null
+++ b/meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping_0.1.bb
@@ -0,0 +1,18 @@
+inherit allarch
+
+SUMMARY = "AGL Device mapping configuration file"
+DESCRIPTION = "This provide default dev-mapping.conf file \
+ that defines mapping between kernel device and logical name \
+ used in low-can binding by example."
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI += "file://dev-mapping.conf.default"
+
+do_install() {
+ install -d ${D}${sysconfdir}
+ install -m 0644 ${WORKDIR}/dev-mapping.conf.default ${D}${sysconfdir}/dev-mapping.conf
+}