summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-core/recipes-platform/images/agl-image-minimal-crosssdk.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-profile-core/recipes-platform/images/agl-image-minimal-crosssdk.bb')
-rwxr-xr-xmeta-agl-profile-core/recipes-platform/images/agl-image-minimal-crosssdk.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-agl-profile-core/recipes-platform/images/agl-image-minimal-crosssdk.bb b/meta-agl-profile-core/recipes-platform/images/agl-image-minimal-crosssdk.bb
new file mode 100755
index 000000000..164e1e9f5
--- /dev/null
+++ b/meta-agl-profile-core/recipes-platform/images/agl-image-minimal-crosssdk.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Cross SDK of Full AGL Distribution for core profile"
+
+DESCRIPTION = "SDK image for full AGL Distribution for IVI profile. \
+It includes the full meta-toolchain, plus developement headers and libraries \
+to form a standalone cross SDK."
+
+require agl-image-minimal.bb
+
+LICENSE = "MIT"
+
+IMAGE_FEATURES_append = " dev-pkgs"
+IMAGE_INSTALL_append = " kernel-dev kernel-devsrc"
+
+inherit populate_sdk
+
+# Task do_populate_sdk and do_rootfs can't be exec simultaneously.
+# Both exec "createrepo" on the same directory, and so one of them
+# can failed (randomly).
+addtask do_populate_sdk after do_rootfs
+