summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-core
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-profile-core')
-rw-r--r--meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping-ci/dev-mapping.conf.ci7
-rw-r--r--meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping-ci_1.0.bb18
-rw-r--r--meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping/dev-mapping.conf.default1
-rw-r--r--meta-agl-profile-core/recipes-core/systemd/systemd/0001-fix-udevd-seclabel-parsing.patch34
-rw-r--r--meta-agl-profile-core/recipes-core/systemd/systemd_%.bbappend1
-rw-r--r--meta-agl-profile-core/recipes-test/pyagl/pyagl_git.bb6
6 files changed, 31 insertions, 36 deletions
diff --git a/meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping-ci/dev-mapping.conf.ci b/meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping-ci/dev-mapping.conf.ci
new file mode 100644
index 000000000..bd5c2135a
--- /dev/null
+++ b/meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping-ci/dev-mapping.conf.ci
@@ -0,0 +1,7 @@
+; Default CAN device mapping
+; Format has to follow ini rules key="value", notice " around value.
+
+[CANbus-mapping]
+hs="vcan0"
+ls="vcan0"
+j1939="vcan0"
diff --git a/meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping-ci_1.0.bb b/meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping-ci_1.0.bb
new file mode 100644
index 000000000..cbba57308
--- /dev/null
+++ b/meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping-ci_1.0.bb
@@ -0,0 +1,18 @@
+SUMMARY = "AGL demo device mapping configuration file"
+DESCRIPTION = "This provides a default dev-mapping.conf file \
+ that defines mapping between kernel device and logical name \
+ used in the low-can binding for the AGL CI setup."
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
+
+SRC_URI += "file://dev-mapping.conf.ci"
+
+inherit allarch
+
+do_install() {
+ install -d ${D}${sysconfdir}
+ install -m 0644 ${WORKDIR}/dev-mapping.conf.ci ${D}${sysconfdir}/dev-mapping.conf
+}
+
+RPROVIDES_${PN} = "virtual/low-can-dev-mapping"
diff --git a/meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping/dev-mapping.conf.default b/meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping/dev-mapping.conf.default
index 7bd8bf2eb..8519a5873 100644
--- a/meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping/dev-mapping.conf.default
+++ b/meta-agl-profile-core/recipes-config/dev-mapping/dev-mapping/dev-mapping.conf.default
@@ -4,3 +4,4 @@
[CANbus-mapping]
hs="can0"
ls="can0"
+j1939="can0"
diff --git a/meta-agl-profile-core/recipes-core/systemd/systemd/0001-fix-udevd-seclabel-parsing.patch b/meta-agl-profile-core/recipes-core/systemd/systemd/0001-fix-udevd-seclabel-parsing.patch
deleted file mode 100644
index 29165b58e..000000000
--- a/meta-agl-profile-core/recipes-core/systemd/systemd/0001-fix-udevd-seclabel-parsing.patch
+++ /dev/null
@@ -1,34 +0,0 @@
-Fix udevd SECLABEL token parsing
-
-The udevd rules parsing rewrite in v243 broke SECLABEL parsing,
-with the result being that udevd crashes when it parses a line
-containing a SECLABEL token. Fix the handling of the attribute
-of SECLABEL tokens when parsing, and add a check to prevent
-crashes if the attribute is missing.
-
-Upstream-Status: Pending
-
-Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-
-diff --git a/src/udev/udev-rules.c b/src/udev/udev-rules.c
-index efea16e5c5..3e757ccb06 100644
---- a/src/udev/udev-rules.c
-+++ b/src/udev/udev-rules.c
-@@ -918,7 +918,7 @@ static int parse_token(UdevRules *rules, const char *key, char *attr, UdevRuleOp
- op = OP_ASSIGN;
- }
-
-- r = rule_line_add_token(rule_line, TK_A_SECLABEL, op, value, NULL);
-+ r = rule_line_add_token(rule_line, TK_A_SECLABEL, op, value, attr);
- } else if (streq(key, "RUN")) {
- if (is_match || op == OP_REMOVE)
- return log_token_invalid_op(rules, key);
-@@ -1927,6 +1927,8 @@ static int udev_rule_apply_token_to_event(
- _cleanup_free_ char *name = NULL, *label = NULL;
- char label_str[UTIL_LINE_SIZE] = {};
-
-+ if (!token->data)
-+ break;
- name = strdup((const char*) token->data);
- if (!name)
- return log_oom();
diff --git a/meta-agl-profile-core/recipes-core/systemd/systemd_%.bbappend b/meta-agl-profile-core/recipes-core/systemd/systemd_%.bbappend
index 242b3d39c..96c4dc35c 100644
--- a/meta-agl-profile-core/recipes-core/systemd/systemd_%.bbappend
+++ b/meta-agl-profile-core/recipes-core/systemd/systemd_%.bbappend
@@ -1,7 +1,6 @@
FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
SRC_URI += "\
- file://0001-fix-udevd-seclabel-parsing.patch \
file://0002-network-add-CAN-Termination-tristate-option.patch \
file://e2fsck.conf \
file://canbus-can.network \
diff --git a/meta-agl-profile-core/recipes-test/pyagl/pyagl_git.bb b/meta-agl-profile-core/recipes-test/pyagl/pyagl_git.bb
index 05e657e2d..21ab3e5d8 100644
--- a/meta-agl-profile-core/recipes-test/pyagl/pyagl_git.bb
+++ b/meta-agl-profile-core/recipes-test/pyagl/pyagl_git.bb
@@ -4,13 +4,17 @@ LICENSE = "Apache-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/pyagl;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "6703d65bc91054d512fccb57a4275b30319a88d7"
+SRCREV = "50083aeb265d767aa8a20fb6fc2c5954a02f8707"
PV = "${AGL_BRANCH}+git${SRCPV}"
S = "${WORKDIR}/git"
inherit setuptools3
+do_install_append() {
+ install -D -m 0755 ${S}/pyagl/scripts/pyagl ${D}${bindir}/pyagl
+}
+
RDEPENDS_${PN} += " \
python3-asyncio \
python3-asyncssh \