summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-graphical-html5/recipes-apis
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-profile-graphical-html5/recipes-apis')
-rw-r--r--meta-agl-profile-graphical-html5/recipes-apis/agl-service-windowmanager/agl-service-windowmanager_git.bbappend9
-rw-r--r--meta-agl-profile-graphical-html5/recipes-apis/agl-service-windowmanager/files/areas.horizontal.json94
2 files changed, 103 insertions, 0 deletions
diff --git a/meta-agl-profile-graphical-html5/recipes-apis/agl-service-windowmanager/agl-service-windowmanager_git.bbappend b/meta-agl-profile-graphical-html5/recipes-apis/agl-service-windowmanager/agl-service-windowmanager_git.bbappend
new file mode 100644
index 000000000..06f89f691
--- /dev/null
+++ b/meta-agl-profile-graphical-html5/recipes-apis/agl-service-windowmanager/agl-service-windowmanager_git.bbappend
@@ -0,0 +1,9 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+
+SRC_URI += " \
+ file://areas.horizontal.json \
+"
+
+do_compile_prepend() {
+ cp ${WORKDIR}/areas.horizontal.json ${S}/conf/areas.json
+}
diff --git a/meta-agl-profile-graphical-html5/recipes-apis/agl-service-windowmanager/files/areas.horizontal.json b/meta-agl-profile-graphical-html5/recipes-apis/agl-service-windowmanager/files/areas.horizontal.json
new file mode 100644
index 000000000..4b6f0c392
--- /dev/null
+++ b/meta-agl-profile-graphical-html5/recipes-apis/agl-service-windowmanager/files/areas.horizontal.json
@@ -0,0 +1,94 @@
+{
+ "areas": [
+ {
+ "name": "fullscreen",
+ "rect": {
+ "x": 0,
+ "y": 0,
+ "w": 1920,
+ "h": 1080
+ }
+ },
+ {
+ "name": "normal.full",
+ "rect": {
+ "x": 218,
+ "y": 0,
+ "w": 1702,
+ "h": 1080
+ }
+ },
+ {
+ "name": "split.main",
+ "rect": {
+ "x": 218,
+ "y": 0,
+ "w": 744,
+ "h": 1080
+ }
+ },
+ {
+ "name": "split.sub",
+ "rect": {
+ "x": 962,
+ "y": 0,
+ "w": 744,
+ "h": 1080
+ }
+ },
+ {
+ "name": "software_keyboard",
+ "rect": {
+ "x": 962,
+ "y": 0,
+ "w": 744,
+ "h": 1080
+ }
+ },
+ {
+ "name": "restriction.normal",
+ "rect": {
+ "x": 218,
+ "y": 0,
+ "w": 1488,
+ "h": 1080
+ }
+ },
+ {
+ "name": "restriction.split.main",
+ "rect": {
+ "x": 218,
+ "y": 0,
+ "w": 744,
+ "h": 1080
+ }
+ },
+ {
+ "name": "restriction.split.sub",
+ "rect": {
+ "x": 962,
+ "y": 0,
+ "w": 744,
+ "h": 1080
+ }
+ },
+ {
+ "name": "on_screen",
+ "rect": {
+ "x": 218,
+ "y": 0,
+ "w": 1488,
+ "h": 1080
+ }
+ },
+ {
+ "name": "remote.fullscreen",
+ "rect": {
+ "x": 0,
+ "y": 0,
+ "w": 720,
+ "h": 640
+ }
+ }
+ ]
+}