summaryrefslogtreecommitdiffstats
path: root/meta-agl-profile-graphical/recipes-graphics/wayland/waltham-transmitter_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl-profile-graphical/recipes-graphics/wayland/waltham-transmitter_git.bb')
-rw-r--r--meta-agl-profile-graphical/recipes-graphics/wayland/waltham-transmitter_git.bb14
1 files changed, 9 insertions, 5 deletions
diff --git a/meta-agl-profile-graphical/recipes-graphics/wayland/waltham-transmitter_git.bb b/meta-agl-profile-graphical/recipes-graphics/wayland/waltham-transmitter_git.bb
index b37304370..9f6684fc4 100644
--- a/meta-agl-profile-graphical/recipes-graphics/wayland/waltham-transmitter_git.bb
+++ b/meta-agl-profile-graphical/recipes-graphics/wayland/waltham-transmitter_git.bb
@@ -4,14 +4,15 @@ HOMEPAGE = "https://github.com/waltham/waltham"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://waltham-transmitter/COPYING;md5=f21c9af4de068fb53b83f0b37d262ec3"
-DEPENDS += "libdrm virtual/kernel wayland waltham weston gstreamer1.0 gstreamer gstreamer1.0-plugins-base gstreamer1.0-plugins-good"
+DEPENDS += "libdrm virtual/kernel wayland wayland-native waltham weston gstreamer1.0 gstreamer gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-plugins-bad wayland-ivi-extension"
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/weston-ivi-plugins.git;protocol=https"
-SRCREV = "b84f9487a32e5b94c93d34a984858a93d0cefc57"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/weston-ivi-plugins.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "0fc0e974749f4ce35e14c23b050aa8fe693c3ce5"
S = "${WORKDIR}/git/"
-WALTHAM_PIPELINE ?= "waltham-transmitter/waltham-renderer/pipeline_example_general.cfg"
+WALTHAM_PIPELINE_TRANSMITTER ?= "waltham-transmitter/waltham-renderer/pipeline_example_general.cfg"
+WALTHAM_PIPELINE_RECEIVER ?= "waltham-receiver/receiver_pipeline_example_general.cfg"
WALTHAM_RECIEVER_IP ?= "192.168.1.2"
WALTHAM_RECEIVER_PORT ?= "3440"
@@ -19,12 +20,15 @@ inherit pkgconfig cmake
do_install_append () {
install -d ${D}/etc/xdg/weston/
- install ${S}/${WALTHAM_PIPELINE} ${D}/etc/xdg/weston/pipeline.cfg
+ install ${S}/${WALTHAM_PIPELINE_TRANSMITTER} ${D}/etc/xdg/weston/pipeline.cfg
+ install ${S}/${WALTHAM_PIPELINE_RECEIVER} ${D}/etc/xdg/weston/receiver_pipeline.cfg
sed -i -e "s/YOUR_RECIEVER_IP/${WALTHAM_RECIEVER_IP}/g" ${D}/etc/xdg/weston/pipeline.cfg
sed -i -e "s/YOUR_RECIEVER_PORT/${WALTHAM_RECEIVER_PORT}/g" ${D}/etc/xdg/weston/pipeline.cfg
+ sed -i -e "s/YOUR_RECIEVER_PORT/${WALTHAM_RECEIVER_PORT}/g" ${D}/etc/xdg/weston/receiver_pipeline.cfg
}
FILES_${PN} += "/etc/xdg/weston/*.cfg"
FILES_${PN} += "${libdir}/*"
+FILES_${PN} += "${bindir}/*"