aboutsummaryrefslogtreecommitdiffstats
path: root/meta-agl/recipes-devtools/libgee/libgee-0.8_0.16.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl/recipes-devtools/libgee/libgee-0.8_0.16.1.bb')
-rw-r--r--meta-agl/recipes-devtools/libgee/libgee-0.8_0.16.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-agl/recipes-devtools/libgee/libgee-0.8_0.16.1.bb b/meta-agl/recipes-devtools/libgee/libgee-0.8_0.16.1.bb
new file mode 100644
index 000000000..3cf16e309
--- /dev/null
+++ b/meta-agl/recipes-devtools/libgee/libgee-0.8_0.16.1.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "libgee is a collection library providing GObject-based interfaces \
+and classes for commonly used data structures."
+HOMEPAGE = "http://live.gnome.org/Libgee"
+SECTION = "libs"
+DEPENDS = "glib-2.0 gobject-introspection-stub"
+
+BBCLASSEXTEND = "native"
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
+
+PE = "1"
+
+inherit autotools vala pkgconfig
+do_configure_prepend() {
+ MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4"
+ for i in ${MACROS}; do
+ rm -f m4/$i
+ done
+}
+
+SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}"
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/libgee/${SHRT_VER}/libgee-${PV}.tar.xz"
+SRC_URI[md5sum] = "d30cf203784431b0fdc3216b1acd999c"
+SRC_URI[sha256sum] = "d95f8ea8e78f843c71b1958fa2fb445e4a325e4821ec23d0d5108d8170e564a5"
+
+S = "${WORKDIR}/libgee-${PV}"