summaryrefslogtreecommitdiffstats
path: root/meta-agl/recipes-devtools/python/python-pycrypto_2.6.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl/recipes-devtools/python/python-pycrypto_2.6.1.bb')
-rw-r--r--meta-agl/recipes-devtools/python/python-pycrypto_2.6.1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-agl/recipes-devtools/python/python-pycrypto_2.6.1.bb b/meta-agl/recipes-devtools/python/python-pycrypto_2.6.1.bb
new file mode 100644
index 000000000..f7a69dc9a
--- /dev/null
+++ b/meta-agl/recipes-devtools/python/python-pycrypto_2.6.1.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Cryptographic modules for Python."
+HOMEPAGE = "http://www.pycrypto.org/"
+LICENSE = "PSFv2"
+LIC_FILES_CHKSUM = "file://COPYRIGHT;md5=35f354d199e8cb7667b059a23578e63d"
+
+DEPENDS += " gmp"
+PYPI_PACKAGE = "pycrypto"
+
+SRC_URI = "file://cross-compiling.patch"
+
+SRC_URI[md5sum] = "55a61a054aa66812daf5161a0d5d7eda"
+SRC_URI[sha256sum] = "f2ce1e989b272cfcb677616763e0a2e7ec659effa67a88aa92b3a65528f60a3c"
+
+inherit pypi autotools-brokensep distutils
+BBCLASSEXTEND = "native"
+do_compile[noexec] = "1"
+
+# We explicitly call distutils_do_install, since we want it to run, but
+# *don't* want the autotools install to run, since this package doesn't
+# provide a "make install" target.
+do_install() {
+ distutils_do_install
+}