summaryrefslogtreecommitdiffstats
path: root/meta-agl/recipes-graphics/wayland/weston
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl/recipes-graphics/wayland/weston')
-rw-r--r--meta-agl/recipes-graphics/wayland/weston/0001-Allow-regular-users-to-launch-Weston_2.0.0.patch (renamed from meta-agl/recipes-graphics/wayland/weston/0001-Allow-regular-users-to-launch-Weston.patch)26
-rw-r--r--meta-agl/recipes-graphics/wayland/weston/0001-compositor-drm.c-Launch-without-input-devices.patch28
2 files changed, 13 insertions, 41 deletions
diff --git a/meta-agl/recipes-graphics/wayland/weston/0001-Allow-regular-users-to-launch-Weston.patch b/meta-agl/recipes-graphics/wayland/weston/0001-Allow-regular-users-to-launch-Weston_2.0.0.patch
index 7b84a67ba..bd1a72b0f 100644
--- a/meta-agl/recipes-graphics/wayland/weston/0001-Allow-regular-users-to-launch-Weston.patch
+++ b/meta-agl/recipes-graphics/wayland/weston/0001-Allow-regular-users-to-launch-Weston_2.0.0.patch
@@ -1,20 +1,20 @@
-From f5555b045a64231d4beaba51cbbf5f5485173900 Mon Sep 17 00:00:00 2001
+From 6c145cea35f0b77613d6e3f48679c976b9839d7c Mon Sep 17 00:00:00 2001
From: Ronan Le Martret <ronan.lemartret@iot.bzh>
-Date: Fri, 14 Apr 2017 19:04:32 +0200
+Date: Wed, 31 May 2017 22:48:18 +0000
Subject: [PATCH] Allow regular users to launch Weston
Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
---
- configure.ac | 6 ++++++
- src/launcher-direct.c | 2 ++
+ configure.ac | 6 ++++++
+ libweston/launcher-direct.c | 2 ++
2 files changed, 8 insertions(+)
diff --git a/configure.ac b/configure.ac
-index 1d11864..4e48d52 100644
+index 7e84c14..8b3e17e 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -131,6 +131,12 @@ if test x$enable_xkbcommon = xyes; then
- COMPOSITOR_MODULES="$COMPOSITOR_MODULES xkbcommon >= 0.3.0"
+@@ -155,6 +155,12 @@ if test x$enable_xkbcommon = xyes; then
+ true)
fi
+AC_ARG_ENABLE(sys-uid, [ --enable-sys-uid],,
@@ -26,11 +26,11 @@ index 1d11864..4e48d52 100644
AC_ARG_ENABLE(setuid-install, [ --enable-setuid-install],,
enable_setuid_install=yes)
AM_CONDITIONAL(ENABLE_SETUID_INSTALL, test x$enable_setuid_install = xyes)
-diff --git a/src/launcher-direct.c b/src/launcher-direct.c
-index 29d9c28..1ac6651 100644
---- a/src/launcher-direct.c
-+++ b/src/launcher-direct.c
-@@ -272,8 +272,10 @@ launcher_direct_connect(struct weston_launcher **out, struct weston_compositor *
+diff --git a/libweston/launcher-direct.c b/libweston/launcher-direct.c
+index 4fc1c3c..8f16a69 100644
+--- a/libweston/launcher-direct.c
++++ b/libweston/launcher-direct.c
+@@ -275,8 +275,10 @@ launcher_direct_connect(struct weston_launcher **out, struct weston_compositor *
{
struct launcher_direct *launcher;
@@ -42,5 +42,5 @@ index 29d9c28..1ac6651 100644
launcher = zalloc(sizeof(*launcher));
if (launcher == NULL)
--
-2.6.6
+2.7.4
diff --git a/meta-agl/recipes-graphics/wayland/weston/0001-compositor-drm.c-Launch-without-input-devices.patch b/meta-agl/recipes-graphics/wayland/weston/0001-compositor-drm.c-Launch-without-input-devices.patch
deleted file mode 100644
index 93b7739fd..000000000
--- a/meta-agl/recipes-graphics/wayland/weston/0001-compositor-drm.c-Launch-without-input-devices.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 43f66e20a6788388df4fc052d257f005c359080f Mon Sep 17 00:00:00 2001
-From: Leon Anavi <leon.anavi@konsulko.com>
-Date: Wed, 14 Dec 2016 12:26:31 +0200
-Subject: [PATCH] compositor-drm.c: Launch without input devices
-
-Launch Weston 11 even if input devices (such as
-a keyboard, a mouse or a touchscreen) are not
-present.
-
-Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
----
- src/compositor-drm.c | 1 -
- 1 file changed, 1 deletion(-)
-
-diff --git a/src/compositor-drm.c b/src/compositor-drm.c
-index fd89627..f66e0af 100644
---- a/src/compositor-drm.c
-+++ b/src/compositor-drm.c
-@@ -3123,7 +3123,6 @@ drm_backend_create(struct weston_compositor *compositor,
- if (udev_input_init(&b->input,
- compositor, b->udev, seat_id) < 0) {
- weston_log("failed to create input devices\n");
-- goto err_sprite;
- }
-
- if (create_outputs(b, config->connector, drm_device) < 0) {
---
-2.7.4