summaryrefslogtreecommitdiffstats
path: root/meta-agl/recipes-ivi
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl/recipes-ivi')
-rw-r--r--meta-agl/recipes-ivi/images/agl-image-ivi.bb16
-rw-r--r--meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-automotive.bb14
-rw-r--r--meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-connectivity.bb14
-rw-r--r--meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-graphics.bb14
-rw-r--r--meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-kernel.bb14
-rw-r--r--meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-multimedia.bb14
-rw-r--r--meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-navi-lbs.bb14
-rw-r--r--meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-os-commonlibs.bb14
-rw-r--r--meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-security.bb14
-rw-r--r--meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-speech-services.bb14
-rw-r--r--meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi.bb23
11 files changed, 165 insertions, 0 deletions
diff --git a/meta-agl/recipes-ivi/images/agl-image-ivi.bb b/meta-agl/recipes-ivi/images/agl-image-ivi.bb
new file mode 100644
index 000000000..e14101edd
--- /dev/null
+++ b/meta-agl/recipes-ivi/images/agl-image-ivi.bb
@@ -0,0 +1,16 @@
+SUMMARY = "A basic system of AGL distribution of IVI profile"
+
+IMAGE_FEATURES += "splash package-management ssh-server-dropbear"
+
+LICENSE = "MIT"
+
+inherit core-image distro_features_check
+
+REQUIRED_DISTRO_FEATURES = "wayland"
+
+CORE_IMAGE_BASE_INSTALL += "weston weston-init weston-examples"
+
+IMAGE_INSTALL_append = "\
+ packagegroup-agl-core \
+ packagegroup-agl-ivi \
+ "
diff --git a/meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-automotive.bb b/meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-automotive.bb
new file mode 100644
index 000000000..f7221517f
--- /dev/null
+++ b/meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-automotive.bb
@@ -0,0 +1,14 @@
+SUMMARY = "The middlewares for AGL IVI profile"
+DESCRIPTION = "The set of packages required by Automotive Subsystem"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-ivi-automotive \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ "
diff --git a/meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-connectivity.bb b/meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-connectivity.bb
new file mode 100644
index 000000000..0b925c096
--- /dev/null
+++ b/meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-connectivity.bb
@@ -0,0 +1,14 @@
+SUMMARY = "The middlewares for AGL IVI profile"
+DESCRIPTION = "The set of packages required by Connectivity Subsystem"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-ivi-connectivity \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ "
diff --git a/meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-graphics.bb b/meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-graphics.bb
new file mode 100644
index 000000000..d7650564b
--- /dev/null
+++ b/meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-graphics.bb
@@ -0,0 +1,14 @@
+SUMMARY = "The middlewares for AGL IVI profile"
+DESCRIPTION = "The set of packages required by Graphics Subsystem"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-ivi-graphics \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ "
diff --git a/meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-kernel.bb b/meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-kernel.bb
new file mode 100644
index 000000000..be51817b7
--- /dev/null
+++ b/meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-kernel.bb
@@ -0,0 +1,14 @@
+SUMMARY = "The middlewares for AGL IVI profile"
+DESCRIPTION = "The set of packages required by Kernel Subsystem"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-ivi-kernel \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ "
diff --git a/meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-multimedia.bb b/meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-multimedia.bb
new file mode 100644
index 000000000..78508eed8
--- /dev/null
+++ b/meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-multimedia.bb
@@ -0,0 +1,14 @@
+SUMMARY = "The middlewares for AGL IVI profile"
+DESCRIPTION = "The set of packages required by Multimedia Subsystem"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-ivi-multimedia \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ "
diff --git a/meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-navi-lbs.bb b/meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-navi-lbs.bb
new file mode 100644
index 000000000..0a3ba2752
--- /dev/null
+++ b/meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-navi-lbs.bb
@@ -0,0 +1,14 @@
+SUMMARY = "The packages of middlewares for AGL IVI profile"
+DESCRIPTION = "The set of packages required by Navigation and Location Based Services Subsystem"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-ivi-navi-lbs \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ "
diff --git a/meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-os-commonlibs.bb b/meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-os-commonlibs.bb
new file mode 100644
index 000000000..0a9de8d5f
--- /dev/null
+++ b/meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-os-commonlibs.bb
@@ -0,0 +1,14 @@
+SUMMARY = "The packages of middlewares for AGL IVI profile"
+DESCRIPTION = "The set of packages required by Operating System and Common libraries Subsystem"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-ivi-os-commonlibs \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ "
diff --git a/meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-security.bb b/meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-security.bb
new file mode 100644
index 000000000..f651c50cd
--- /dev/null
+++ b/meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-security.bb
@@ -0,0 +1,14 @@
+SUMMARY = "The packages of middlewares for AGL IVI profile"
+DESCRIPTION = "The set of packages required by Security Subsystem"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-ivi-security \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ "
diff --git a/meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-speech-services.bb b/meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-speech-services.bb
new file mode 100644
index 000000000..eccebee9f
--- /dev/null
+++ b/meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi-speech-services.bb
@@ -0,0 +1,14 @@
+SUMMARY = "The packages of middlewares for AGL IVI profile"
+DESCRIPTION = "The set of packages required by Speech Services Subsystem"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-ivi-speech-services \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ "
diff --git a/meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi.bb b/meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi.bb
new file mode 100644
index 000000000..bafb8e024
--- /dev/null
+++ b/meta-agl/recipes-ivi/packagegroups/packagegroup-agl-ivi.bb
@@ -0,0 +1,23 @@
+SUMMARY = "The middlewares for AGL IVI profile"
+DESCRIPTION = "The set of packages required for AGL Distribution"
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+ packagegroup-agl-ivi \
+ "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+ packagegroup-agl-ivi-automotive \
+ packagegroup-agl-ivi-connectivity \
+ packagegroup-agl-ivi-graphics \
+ packagegroup-agl-ivi-multimedia \
+ packagegroup-agl-ivi-navi-lbs \
+ packagegroup-agl-ivi-os-commonlibs \
+ packagegroup-agl-ivi-speech-services \
+ packagegroup-agl-ivi-security \
+ packagegroup-agl-ivi-kernel \
+ "