aboutsummaryrefslogtreecommitdiffstats
path: root/meta-agl/recipes-sota/ostree/ostree_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl/recipes-sota/ostree/ostree_git.bb')
-rw-r--r--meta-agl/recipes-sota/ostree/ostree_git.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-agl/recipes-sota/ostree/ostree_git.bb b/meta-agl/recipes-sota/ostree/ostree_git.bb
new file mode 100644
index 000000000..9009685d4
--- /dev/null
+++ b/meta-agl/recipes-sota/ostree/ostree_git.bb
@@ -0,0 +1,25 @@
+SUMMARY = "Tool for managing bootable, immutable, versioned filesystem trees"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2"
+
+SRC_URI = "gitsm://git.gnome.org/ostree.git;branch=master"
+SRCREV="${AUTOREV}"
+
+S = "${WORKDIR}/git"
+
+DEPENDS += "attr libarchive glib-2.0 pkgconfig gpgme libgsystem fuse libsoup-2.4"
+
+RDEPENDS_${PN} = "python libsystemd util-linux-libuuid util-linux-libblkid util-linux-libmount libcap liblzma"
+
+inherit autotools-brokensep
+
+EXTRA_OECONF = "--with-libarchive --disable-gtk-doc --disable-gtk-doc-html --disable-gtk-doc-pdf --disable-man"
+
+FILES_${PN} += "${libdir}/ostree/ ${libdir}/ostbuild"
+
+BBCLASSEXTEND = "native"
+
+do_configure() {
+ NOCONFIGURE=true ./autogen.sh
+ oe_runconf
+}