summaryrefslogtreecommitdiffstats
path: root/meta-agl
diff options
context:
space:
mode:
Diffstat (limited to 'meta-agl')
-rw-r--r--meta-agl/recipes-connectivity/rygel/rygel_%.bbappend2
-rw-r--r--meta-agl/recipes-core/dbus/dbus_%.bbappend6
-rw-r--r--meta-agl/recipes-core/systemd/systemd_%.bbappend2
-rw-r--r--meta-agl/recipes-graphics/wayland/weston_%.bbappend2
-rw-r--r--meta-agl/recipes-multimedia/lightmediascanner/lightmediascanner_%.bbappend2
5 files changed, 7 insertions, 7 deletions
diff --git a/meta-agl/recipes-connectivity/rygel/rygel_%.bbappend b/meta-agl/recipes-connectivity/rygel/rygel_%.bbappend
index 3f3f74969..9d4713ce1 100644
--- a/meta-agl/recipes-connectivity/rygel/rygel_%.bbappend
+++ b/meta-agl/recipes-connectivity/rygel/rygel_%.bbappend
@@ -13,7 +13,7 @@ inherit systemd
do_install_append() {
# Install rygel systemd service
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
- install -p -D ${WORKDIR}/rygel.service ${D}${systemd_user_unitdir}/rygel.service
+ install -m 644 -p -D ${WORKDIR}/rygel.service ${D}${systemd_user_unitdir}/rygel.service
# Execute these manually on behalf of systemctl script (from systemd-systemctl-native.bb)
# because it does not support systemd's user mode.
diff --git a/meta-agl/recipes-core/dbus/dbus_%.bbappend b/meta-agl/recipes-core/dbus/dbus_%.bbappend
index 348be60c1..b27e44d99 100644
--- a/meta-agl/recipes-core/dbus/dbus_%.bbappend
+++ b/meta-agl/recipes-core/dbus/dbus_%.bbappend
@@ -9,9 +9,9 @@ inherit systemd
do_install_append() {
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
- install -p -D ${WORKDIR}/dbus.service ${D}${systemd_user_unitdir}/dbus.service
- install -p -D ${WORKDIR}/dbus.socket ${D}${systemd_user_unitdir}/dbus.socket
- install -p -D ${WORKDIR}/dbus_env.conf ${D}${systemd_system_unitdir}/user@.service.d/dbus_env.conf
+ install -m 644 -p -D ${WORKDIR}/dbus.service ${D}${systemd_user_unitdir}/dbus.service
+ install -m 644 -p -D ${WORKDIR}/dbus.socket ${D}${systemd_user_unitdir}/dbus.socket
+ install -m 644 -p -D ${WORKDIR}/dbus_env.conf ${D}${systemd_system_unitdir}/user@.service.d/dbus_env.conf
# Execute these manually on behalf of systemctl script (from systemd-systemctl-native.bb)
# because it does not support systemd's user mode.
diff --git a/meta-agl/recipes-core/systemd/systemd_%.bbappend b/meta-agl/recipes-core/systemd/systemd_%.bbappend
index ef926953c..4e0d5d474 100644
--- a/meta-agl/recipes-core/systemd/systemd_%.bbappend
+++ b/meta-agl/recipes-core/systemd/systemd_%.bbappend
@@ -7,7 +7,7 @@ PACKAGECONFIG_append_pn-systemd = " networkd"
do_install_append() {
# Install /etc/e2fsck.conf to avoid boot stuck by wrong clock time
- install -p -D ${WORKDIR}/e2fsck.conf ${D}/etc/e2fsck.conf
+ install -m 644 -p -D ${WORKDIR}/e2fsck.conf ${D}/etc/e2fsck.conf
}
FILES_${PN} += " /etc/e2fsck.conf "
diff --git a/meta-agl/recipes-graphics/wayland/weston_%.bbappend b/meta-agl/recipes-graphics/wayland/weston_%.bbappend
index 2ee7150e5..6ad42fc77 100644
--- a/meta-agl/recipes-graphics/wayland/weston_%.bbappend
+++ b/meta-agl/recipes-graphics/wayland/weston_%.bbappend
@@ -13,7 +13,7 @@ SYSTEMD_SERVICE_${PN} = "weston.service"
do_install_append() {
# Install systemd unit files
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
- install -p -D ${WORKDIR}/weston.service ${D}${systemd_system_unitdir}/weston.service
+ install -m 644 -p -D ${WORKDIR}/weston.service ${D}${systemd_system_unitdir}/weston.service
fi
WESTON_INI_CONFIG=${sysconfdir}/xdg/weston
diff --git a/meta-agl/recipes-multimedia/lightmediascanner/lightmediascanner_%.bbappend b/meta-agl/recipes-multimedia/lightmediascanner/lightmediascanner_%.bbappend
index f9c269d2e..521724f32 100644
--- a/meta-agl/recipes-multimedia/lightmediascanner/lightmediascanner_%.bbappend
+++ b/meta-agl/recipes-multimedia/lightmediascanner/lightmediascanner_%.bbappend
@@ -10,7 +10,7 @@ inherit systemd
do_install_append() {
# Install LMS systemd service
if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
- install -p -D ${WORKDIR}/lightmediascanner.service ${D}${systemd_user_unitdir}/lightmediascanner.service
+ install -m 644 -p -D ${WORKDIR}/lightmediascanner.service ${D}${systemd_user_unitdir}/lightmediascanner.service
# Execute these manually on behalf of systemctl script (from systemd-systemctl-native.bb)
# because it does not support systemd's user mode.