aboutsummaryrefslogtreecommitdiffstats
path: root/meta-app-framework/recipes-config/agl-users/agl-users_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-app-framework/recipes-config/agl-users/agl-users_0.1.bb')
-rw-r--r--meta-app-framework/recipes-config/agl-users/agl-users_0.1.bb65
1 files changed, 0 insertions, 65 deletions
diff --git a/meta-app-framework/recipes-config/agl-users/agl-users_0.1.bb b/meta-app-framework/recipes-config/agl-users/agl-users_0.1.bb
deleted file mode 100644
index 0f61248db..000000000
--- a/meta-app-framework/recipes-config/agl-users/agl-users_0.1.bb
+++ /dev/null
@@ -1,65 +0,0 @@
-inherit allarch useradd
-
-SUMMARY = "AGL Users Seed"
-DESCRIPTION = "This is a core framework component that\
- defines how users are managed and who are the default users."
-
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-
-
-SRC_URI = ""
-
-
-RDEPENDS_${PN}_append_smack = " smack-userspace"
-DEPENDS_append_smack = " smack-userspace-native"
-
-ALLOW_EMPTY_${PN} = "1"
-
-USERADD_PACKAGES = "${PN}"
-
-USERADD_PARAM_${PN} = "\
- -g users -d /home/agl-driver -m -K PASS_MAX_DAYS=-1 agl-driver ; \
- -g users -d /home/agl-passenger -m -K PASS_MAX_DAYS=-1 agl-passenger \
-"
-
-
-do_configure() {
- :
-}
-
-do_compile() {
- :
-}
-
-do_install() {
- :
-}
-
-
-pkg_postinst_${PN}() {
- #!/bin/sh -e
-
- # avoid to run on host
- [ x"$D" != "x" ] && exit 1
-
- # Drops password
- passwd -d agl-driver
- passwd -d agl-passenger
-}
-
-pkg_postinst_${PN}_smack() {
- #!/bin/sh -e
-
- # avoid to run on host
- [ x"$D" != "x" ] && exit 1
-
- # Actions to carry out on the device go here
- for x in /etc/skel /home/*
- do
- chsmack -a User::Home $x
- done
- passwd -d agl-driver
- passwd -d agl-passenger
-}
-