aboutsummaryrefslogtreecommitdiffstats
path: root/meta-app-framework/recipes-config
diff options
context:
space:
mode:
Diffstat (limited to 'meta-app-framework/recipes-config')
-rw-r--r--meta-app-framework/recipes-config/agl-users/agl-users_0.1.bb27
-rw-r--r--meta-app-framework/recipes-config/dev-mapping/dev-mapping/dev-mapping.conf.default6
-rw-r--r--meta-app-framework/recipes-config/dev-mapping/dev-mapping_0.1.bb18
3 files changed, 0 insertions, 51 deletions
diff --git a/meta-app-framework/recipes-config/agl-users/agl-users_0.1.bb b/meta-app-framework/recipes-config/agl-users/agl-users_0.1.bb
deleted file mode 100644
index 79a9461e0..000000000
--- a/meta-app-framework/recipes-config/agl-users/agl-users_0.1.bb
+++ /dev/null
@@ -1,27 +0,0 @@
-inherit allarch useradd
-
-SUMMARY = "AGL Users Seed"
-DESCRIPTION = "This is a core framework component that\
- defines how users are managed and who are the default users."
-
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-
-ALLOW_EMPTY_${PN} = "1"
-
-USERADD_PACKAGES = "${PN}"
-
-USERADDEXTENSION = "useradd-staticids"
-
-GROUPADD_PARAM_${PN} = "\
- --system display ; \
- --system weston-launch ; \
- -g 1001 agl-driver ; \
- -g 1002 agl-passenger \
-"
-
-USERADD_PARAM_${PN} = "\
- -g 1001 -G display -u 1001 -o -d /home/1001 -m -K PASS_MAX_DAYS=-1 agl-driver ; \
- -g 1002 -G display -u 1002 -o -d /home/1002 -m -K PASS_MAX_DAYS=-1 agl-passenger ; \
- --gid display --groups weston-launch,video,input --home-dir /run/platform/display --shell /bin/false --comment \"Display daemon\" --key PASS_MAX_DAYS=-1 display \
-"
diff --git a/meta-app-framework/recipes-config/dev-mapping/dev-mapping/dev-mapping.conf.default b/meta-app-framework/recipes-config/dev-mapping/dev-mapping/dev-mapping.conf.default
deleted file mode 100644
index 7bd8bf2eb..000000000
--- a/meta-app-framework/recipes-config/dev-mapping/dev-mapping/dev-mapping.conf.default
+++ /dev/null
@@ -1,6 +0,0 @@
-; Default CAN device mapping
-; Format has to follow ini rules key="value", notice " around value.
-
-[CANbus-mapping]
-hs="can0"
-ls="can0"
diff --git a/meta-app-framework/recipes-config/dev-mapping/dev-mapping_0.1.bb b/meta-app-framework/recipes-config/dev-mapping/dev-mapping_0.1.bb
deleted file mode 100644
index befb5443f..000000000
--- a/meta-app-framework/recipes-config/dev-mapping/dev-mapping_0.1.bb
+++ /dev/null
@@ -1,18 +0,0 @@
-inherit allarch
-
-SUMMARY = "AGL Device mapping configuration file"
-DESCRIPTION = "This provide default dev-mapping.conf file \
- that defines mapping between kernel device and logical name \
- used in low-can binding by example."
-
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
-
-SRC_URI += "file://dev-mapping.conf.default"
-
-do_install() {
- install -d ${D}${sysconfdir}
- install -m 0644 ${WORKDIR}/dev-mapping.conf.default ${D}${sysconfdir}/dev-mapping.conf
-}