summaryrefslogtreecommitdiffstats
path: root/meta-app-framework/recipes-core/applaunchd/applaunchd_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-app-framework/recipes-core/applaunchd/applaunchd_git.bb')
-rw-r--r--meta-app-framework/recipes-core/applaunchd/applaunchd_git.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta-app-framework/recipes-core/applaunchd/applaunchd_git.bb b/meta-app-framework/recipes-core/applaunchd/applaunchd_git.bb
index 0aef4e003..e6439c3dd 100644
--- a/meta-app-framework/recipes-core/applaunchd/applaunchd_git.bb
+++ b/meta-app-framework/recipes-core/applaunchd/applaunchd_git.bb
@@ -17,6 +17,7 @@ SRC_URI = " \
git://gerrit.automotivelinux.org/gerrit/src/applaunchd;protocol=https;branch=${AGL_BRANCH} \
file://agl-app@.service \
file://agl-app-web@.service \
+ file://agl-app-flutter@.service \
file://no-network.conf \
file://private-tmp.conf \
"
@@ -31,6 +32,7 @@ do_install:append() {
install -d ${D}${systemd_system_unitdir}
install -m 644 ${WORKDIR}/agl-app@.service ${D}${systemd_system_unitdir}/
install -m 644 ${WORKDIR}/agl-app-web@.service ${D}${systemd_system_unitdir}/
+ install -m 644 ${WORKDIR}/agl-app-flutter@.service ${D}${systemd_system_unitdir}/
# Install individual sandboxing overrides/drop-ins to be used by apps
install -d ${D}${systemd_system_unitdir}/sandboxing
@@ -38,7 +40,7 @@ do_install:append() {
install -m 644 ${WORKDIR}/private-tmp.conf ${D}${systemd_system_unitdir}/sandboxing/
}
-PACKAGE_BEFORE_PN += "${PN}-template-agl-app ${PN}-template-agl-app-web"
+PACKAGE_BEFORE_PN += "${PN}-template-agl-app ${PN}-template-agl-app-web ${PN}-template-agl-app-flutter"
FILES:${PN} += "${systemd_system_unitdir} ${datadir}/dbus-1/"
@@ -46,6 +48,8 @@ FILES:${PN}-template-agl-app = "${systemd_system_unitdir}/agl-app@.service"
FILES:${PN}-template-agl-app-web = "${systemd_system_unitdir}/agl-app-web@.service"
+FILES:${PN}-template-agl-app-flutter = "${systemd_system_unitdir}/agl-app-flutter@.service"
+
RDEPENDS:${PN} += " \
agl-session \
polkit-rule-agl-app \
@@ -54,3 +58,5 @@ RDEPENDS:${PN} += " \
RDEPENDS:${PN}-template-agl-app = "${PN}"
RDEPENDS:${PN}-template-agl-app-web = "${PN}"
+
+RDEPENDS:${PN}-template-agl-app-flutter = "${PN}"