summaryrefslogtreecommitdiffstats
path: root/meta-app-framework/recipes-core/web-runtime
diff options
context:
space:
mode:
Diffstat (limited to 'meta-app-framework/recipes-core/web-runtime')
-rwxr-xr-xmeta-app-framework/recipes-core/web-runtime/web-runtime/web-runtime2
-rw-r--r--meta-app-framework/recipes-core/web-runtime/web-runtime/web-runtime-webkit.qml13
-rw-r--r--meta-app-framework/recipes-core/web-runtime/web-runtime/web-runtime.qml14
-rw-r--r--meta-app-framework/recipes-core/web-runtime/web-runtime_0.1.bb42
4 files changed, 0 insertions, 71 deletions
diff --git a/meta-app-framework/recipes-core/web-runtime/web-runtime/web-runtime b/meta-app-framework/recipes-core/web-runtime/web-runtime/web-runtime
deleted file mode 100755
index 80685eb81..000000000
--- a/meta-app-framework/recipes-core/web-runtime/web-runtime/web-runtime
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/bin/sh
-exec /usr/bin/qt5/qmlscene "$1" /usr/bin/web-runtime.qml
diff --git a/meta-app-framework/recipes-core/web-runtime/web-runtime/web-runtime-webkit.qml b/meta-app-framework/recipes-core/web-runtime/web-runtime/web-runtime-webkit.qml
deleted file mode 100644
index d18b672cd..000000000
--- a/meta-app-framework/recipes-core/web-runtime/web-runtime/web-runtime-webkit.qml
+++ /dev/null
@@ -1,13 +0,0 @@
-import QtQuick 2.1
-import QtQuick.Controls 1.1
-import QtWebKit 3.0
-
-ApplicationWindow {
- width: 1024
- height: 768
- visible: true
- WebView {
- url: Qt.application.arguments[1]
- anchors.fill: parent
- }
-}
diff --git a/meta-app-framework/recipes-core/web-runtime/web-runtime/web-runtime.qml b/meta-app-framework/recipes-core/web-runtime/web-runtime/web-runtime.qml
deleted file mode 100644
index 852567a49..000000000
--- a/meta-app-framework/recipes-core/web-runtime/web-runtime/web-runtime.qml
+++ /dev/null
@@ -1,14 +0,0 @@
-import QtQuick 2.1
-import QtQuick.Controls 1.1
-import QtWebEngine 1.1
-
-ApplicationWindow {
- width: 1024
- height: 768
- visible: true
- flags: Qt.WindowFullScreen | Qt.FramelessWindowHint
- WebEngineView {
- url: Qt.application.arguments[1]
- anchors.fill: parent
- }
-}
diff --git a/meta-app-framework/recipes-core/web-runtime/web-runtime_0.1.bb b/meta-app-framework/recipes-core/web-runtime/web-runtime_0.1.bb
deleted file mode 100644
index 75077b696..000000000
--- a/meta-app-framework/recipes-core/web-runtime/web-runtime_0.1.bb
+++ /dev/null
@@ -1,42 +0,0 @@
-inherit allarch
-
-SUMMARY = "Provides the 'web-runtime' command"
-DESCRIPTION = "The command 'web-runtime' is an abstraction that allows to "
-
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-
-SRC_URI = "\
- file://web-runtime;md5sum=2245be1e6029b30966f0842e3fee75ea \
- file://web-runtime.qml;md5sum=922aeae6d596d7c83af01abca266f0df \
- file://web-runtime-webkit.qml;md5sum=4daf9df39078634c27a7923d37e82e3d \
-"
-
-RDEPENDS_${PN} = "\
- qtdeclarative-tools \
- qtwayland-qmlplugins \
- qtquickcontrols-qmlplugins \
-"
-
-PROVIDES += "virtual/webruntime"
-# add also RPROVIDES to satisfy the packagegroup
-RPROVIDES_${PN} += "virtual/webruntime"
-
-do_configure() {
- :
-}
-
-do_install() {
- install -d ${D}${bindir}
- install -m 0755 ${WORKDIR}/web-runtime ${D}${bindir}/web-runtime
- install -m 0644 ${WORKDIR}/web-runtime.qml ${D}${bindir}/web-runtime.qml
- install -m 0644 ${WORKDIR}/web-runtime-webkit.qml ${D}${bindir}/web-runtime-webkit.qml
-}
-
-do_install_append_rcar-gen2() {
- # workaround for porter board: force the use of libEGL provided by mesa at runtime
- # otherwise, the proprietary libEGL is used and a problem then occurs due to a missing EGL function
- sed -i 's|^\(exec /usr/bin/qt5/qmlscene\)|LD_PRELOAD=/usr/lib/libEGL.so \1|g' ${D}${bindir}/web-runtime
-}
-
-