summaryrefslogtreecommitdiffstats
path: root/meta-app-framework/recipes-platform/packagegroups/packagegroup-security-framework.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-app-framework/recipes-platform/packagegroups/packagegroup-security-framework.bb')
-rw-r--r--meta-app-framework/recipes-platform/packagegroups/packagegroup-security-framework.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-app-framework/recipes-platform/packagegroups/packagegroup-security-framework.bb b/meta-app-framework/recipes-platform/packagegroups/packagegroup-security-framework.bb
index 6b32b0349..449ce6432 100644
--- a/meta-app-framework/recipes-platform/packagegroups/packagegroup-security-framework.bb
+++ b/meta-app-framework/recipes-platform/packagegroups/packagegroup-security-framework.bb
@@ -14,7 +14,7 @@ inherit packagegroup
# Without configuration, security-manager is not usable. We use
# the policy packaged from the upstream source code here. Adapting
# it for the distro can be done by patching that source.
-RDEPENDS_${PN}_append_with-lsm-smack = " \
+RDEPENDS:${PN}:append:with-lsm-smack = " \
cynagora \
security-manager \
security-manager-policy \
: #3333bb; background-color: #fff0f0 } /* Literal.String.Interpol */ .highlight .sx { color: #22bb22; background-color: #f0fff0 } /* Literal.String.Other */ .highlight .sr { color: #008800; background-color: #fff0ff } /* Literal.String.Regex */ .highlight .s1 { color: #dd2200; background-color: #fff0f0 } /* Literal.String.Single */ .highlight .ss { color: #aa6600; background-color: #fff0f0 } /* Literal.String.Symbol */ .highlight .bp { color: #003388 } /* Name.Builtin.Pseudo */ .highlight .fm { color: #0066bb; font-weight: bold } /* Name.Function.Magic */ .highlight .vc { color: #336699 } /* Name.Variable.Class */ .highlight .vg { color: #dd7700 } /* Name.Variable.Global */ .highlight .vi { color: #3333bb } /* Name.Variable.Instance */ .highlight .vm { color: #336699 } /* Name.Variable.Magic */ .highlight .il { color: #0000DD; font-weight: bold } /* Literal.Number.Integer.Long */
SUMMARY = "Python client for KUKSA.val, the KUKSA Vehicle Abstraction Layer"
HOMEPAGE = "https://github.com/eclipse/kuksa.val"
BUGTRACKER = "https://github.com/eclipse/kuksa.val/issues"

LICENSE = "EPL-2.0"
LIC_FILES_CHKSUM = "file://LICENSE;md5=d9fc0efef5228704e7f5b37f27192723"

DEPENDS = "python3-setuptools-git-versioning-native"

require kuksa-val.inc

SRC_URI += "file://0001-kuksa_viss_client-fix-SSL-context-creation.patch"

inherit setuptools3

RDEPENDS:${PN} += " \
    python3-cmd2 \
    python3-importlib-metadata \
    python3-pkg-resources \
    python3-pygments \
    python3-websockets \
"

# A script for generating new certificates currently gets shipped inside
# the client module, for now add bash to RDEPENDS to quiet the QA error.
# This should probably be addressed with finer-grained packaging or some
# other change worked out with upstream.
RDEPENDS:${PN} += "bash"