summaryrefslogtreecommitdiffstats
path: root/meta-app-framework
diff options
context:
space:
mode:
Diffstat (limited to 'meta-app-framework')
-rw-r--r--meta-app-framework/classes/aglwgt.bbclass3
-rw-r--r--meta-app-framework/recipes-core/af-binder/af-binder-devtools_1.0.bb19
-rw-r--r--meta-app-framework/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bbappend2
3 files changed, 23 insertions, 1 deletions
diff --git a/meta-app-framework/classes/aglwgt.bbclass b/meta-app-framework/classes/aglwgt.bbclass
index ce566abca..aa27c2492 100644
--- a/meta-app-framework/classes/aglwgt.bbclass
+++ b/meta-app-framework/classes/aglwgt.bbclass
@@ -15,6 +15,9 @@ DEPENDS_append = " af-main-native"
# for bindings af-binder is required.
DEPENDS_append = " af-binder"
+# for hal bindings genskel is required.
+DEPENDS_append = " af-binder-devtools-native"
+
do_aglwgt_package() {
cd ${B}
${S}/conf.d/autobuild/agl/autobuild package BUILD_DIR=${B} DEST=${B}/package VERBOSE=TRUE || \
diff --git a/meta-app-framework/recipes-core/af-binder/af-binder-devtools_1.0.bb b/meta-app-framework/recipes-core/af-binder/af-binder-devtools_1.0.bb
new file mode 100644
index 000000000..d22112f22
--- /dev/null
+++ b/meta-app-framework/recipes-core/af-binder/af-binder-devtools_1.0.bb
@@ -0,0 +1,19 @@
+SUMMARY = "App Framework Host Utilities (generators, parsers)"
+DESCRIPTION = "The AGL App Framework Host Utilities are used to compile applications"
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/src/app-framework-host-utilities"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE-2.0.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+DEPENDS = "json-c"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-host-utilities;protocol=https;branch=${AGL_BRANCH}"
+
+SRCREV = "${AGL_DEFAULT_REVISION}"
+PV = "${AGL_BRANCH}+git${SRCPV}"
+
+S = "${WORKDIR}/git"
+
+inherit cmake pkgconfig
+
+BBCLASSEXTEND += "native nativesdk"
diff --git a/meta-app-framework/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bbappend b/meta-app-framework/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bbappend
index ca0b54f73..fc73e8f3d 100644
--- a/meta-app-framework/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bbappend
+++ b/meta-app-framework/recipes-core/packagegroups/nativesdk-packagegroup-sdk-host.bbappend
@@ -1,2 +1,2 @@
-RDEPENDS_${PN} =+ "nativesdk-af-main-tools"
+RDEPENDS_${PN} =+ "nativesdk-af-main-tools nativesdk-af-binder-devtools"
ef='#n221'>221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288