summaryrefslogtreecommitdiffstats
path: root/meta-app-framework
diff options
context:
space:
mode:
Diffstat (limited to 'meta-app-framework')
-rw-r--r--meta-app-framework/recipes-config/agl-login-manager/agl-login-manager_0.1.bb47
-rw-r--r--meta-app-framework/recipes-config/agl-login-manager/files/agl-user-session.pamd3
-rw-r--r--meta-app-framework/recipes-config/agl-login-manager/files/agl-user-session@.service18
-rw-r--r--meta-app-framework/recipes-config/agl-login-manager/files/user-config.path8
-rw-r--r--meta-app-framework/recipes-config/agl-login-manager/files/user-config.service8
-rw-r--r--meta-app-framework/recipes-graphics/agl-desktop-config/agl-desktop-config_0.1.bb21
-rw-r--r--meta-app-framework/recipes-graphics/agl-desktop-config/files/user-weston-term.path8
-rw-r--r--meta-app-framework/recipes-graphics/agl-desktop-config/files/user-weston-term.service12
8 files changed, 0 insertions, 125 deletions
diff --git a/meta-app-framework/recipes-config/agl-login-manager/agl-login-manager_0.1.bb b/meta-app-framework/recipes-config/agl-login-manager/agl-login-manager_0.1.bb
deleted file mode 100644
index c86838268..000000000
--- a/meta-app-framework/recipes-config/agl-login-manager/agl-login-manager_0.1.bb
+++ /dev/null
@@ -1,47 +0,0 @@
-SUMMARY = "AGL Login manager"
-
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-
-inherit agl-graphical
-
-SRC_URI += " \
- file://user-config.service \
- file://user-config.path \
- file://agl-user-session.pamd \
- file://agl-user-session@.service \
-"
-
-LOGIN_USER ??="agl-driver agl-passenger"
-
-do_install_append() {
-
- install -d ${D}${sysconfdir}/pam.d/
- install -m 0644 ${WORKDIR}/agl-user-session.pamd ${D}${sysconfdir}/pam.d/agl-user-session
-
- install -d ${D}${systemd_user_unitdir}
- install -d ${D}${systemd_user_unitdir}/default.target.wants
- install -m 0644 ${WORKDIR}/user-config.service ${D}${systemd_user_unitdir}
- install -m 0644 ${WORKDIR}/user-config.path ${D}${systemd_user_unitdir}
-
- sed -e 's,@DISPLAY_XDG_RUNTIME_DIR@,${DISPLAY_XDG_RUNTIME_DIR},g' \
- -i ${D}${systemd_user_unitdir}/user-config.service
- sed -e 's,@DISPLAY_XDG_RUNTIME_DIR@,${DISPLAY_XDG_RUNTIME_DIR},g' \
- -i ${D}${systemd_user_unitdir}/user-config.path
-
- ln -sf ${systemd_user_unitdir}/user-config.path ${D}${systemd_user_unitdir}/default.target.wants
-
- install -d ${D}${systemd_unitdir}/system/
- install -d ${D}${systemd_unitdir}/system/multi-user.target.wants/
- install -m 0644 ${WORKDIR}/agl-user-session@.service ${D}${systemd_unitdir}/system/
-
- for AGL_USER in ${LOGIN_USER};do
- ln -sf ${systemd_system_unitdir}/agl-user-session@.service ${D}${systemd_unitdir}/system/multi-user.target.wants/agl-user-session@${AGL_USER}.service;
- done
-}
-
-FILES_${PN} += "${sysconfdir}/pam.d/agl-user-session"
-FILES_${PN} += "${systemd_user_unitdir}/*"
-FILES_${PN} += "${libdir}/systemd/user/default.target.wants/*"
-FILES_${PN} += "${systemd_unitdir}/system/agl-user-session@.service"
-FILES_${PN} += "${systemd_unitdir}/system/multi-user.target.wants/*"
diff --git a/meta-app-framework/recipes-config/agl-login-manager/files/agl-user-session.pamd b/meta-app-framework/recipes-config/agl-login-manager/files/agl-user-session.pamd
deleted file mode 100644
index 462c3648b..000000000
--- a/meta-app-framework/recipes-config/agl-login-manager/files/agl-user-session.pamd
+++ /dev/null
@@ -1,3 +0,0 @@
-account include common-account
-session required pam_loginuid.so
-session include common-session
diff --git a/meta-app-framework/recipes-config/agl-login-manager/files/agl-user-session@.service b/meta-app-framework/recipes-config/agl-login-manager/files/agl-user-session@.service
deleted file mode 100644
index b128a40c8..000000000
--- a/meta-app-framework/recipes-config/agl-login-manager/files/agl-user-session@.service
+++ /dev/null
@@ -1,18 +0,0 @@
-# This file is part of systemd.
-#
-# systemd is free software; you can redistribute it and/or modify it
-# under the terms of the GNU Lesser General Public License as published by
-# the Free Software Foundation; either version 2.1 of the License, or
-# (at your option) any later version.
-
-[Unit]
-Description=User Manager for UID %i
-After=systemd-user-sessions.service
-
-[Service]
-User=%i
-PAMName=agl-user-session
-ExecStart=-/bin/sleep 2147483648
-KillMode=mixed
-Delegate=yes
-TasksMax=infinity
diff --git a/meta-app-framework/recipes-config/agl-login-manager/files/user-config.path b/meta-app-framework/recipes-config/agl-login-manager/files/user-config.path
deleted file mode 100644
index 07f61f646..000000000
--- a/meta-app-framework/recipes-config/agl-login-manager/files/user-config.path
+++ /dev/null
@@ -1,8 +0,0 @@
-[Unit]
-Description=AGL user config unit path
-
-[Path]
-PathExists=@DISPLAY_XDG_RUNTIME_DIR@/wayland-0
-
-[Install]
-WantedBy=default.target
diff --git a/meta-app-framework/recipes-config/agl-login-manager/files/user-config.service b/meta-app-framework/recipes-config/agl-login-manager/files/user-config.service
deleted file mode 100644
index 0bf37fb4b..000000000
--- a/meta-app-framework/recipes-config/agl-login-manager/files/user-config.service
+++ /dev/null
@@ -1,8 +0,0 @@
-[Unit]
-Description=AGL user config
-
-[Service]
-ExecStart=/bin/ln -sf @DISPLAY_XDG_RUNTIME_DIR@/wayland-0 %t/
-
-[Install]
-WantedBy=default.target
diff --git a/meta-app-framework/recipes-graphics/agl-desktop-config/agl-desktop-config_0.1.bb b/meta-app-framework/recipes-graphics/agl-desktop-config/agl-desktop-config_0.1.bb
deleted file mode 100644
index e0358d615..000000000
--- a/meta-app-framework/recipes-graphics/agl-desktop-config/agl-desktop-config_0.1.bb
+++ /dev/null
@@ -1,21 +0,0 @@
-SUMMARY = "AGL desktop config"
-
-LICENSE = "MIT"
-LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
-
-SRC_URI += " \
- file://user-weston-term.service \
- file://user-weston-term.path \
-"
-
-do_install_append() {
- install -d ${D}${systemd_user_unitdir}
- install -m 0644 ${WORKDIR}/user-weston-term.service ${D}${systemd_user_unitdir}
- install -m 0644 ${WORKDIR}/user-weston-term.path ${D}${systemd_user_unitdir}
-
- install -d ${D}${systemd_user_unitdir}/default.target.wants
- ln -sf ${systemd_user_unitdir}/user-weston-term.path ${D}${libdir}/systemd/user/default.target.wants
-}
-
-FILES_${PN} += "${systemd_user_unitdir}/*"
-FILES_${PN} += "${systemd_user_unitdir}/default.target.wants/default.target.wants"
diff --git a/meta-app-framework/recipes-graphics/agl-desktop-config/files/user-weston-term.path b/meta-app-framework/recipes-graphics/agl-desktop-config/files/user-weston-term.path
deleted file mode 100644
index 9481840e5..000000000
--- a/meta-app-framework/recipes-graphics/agl-desktop-config/files/user-weston-term.path
+++ /dev/null
@@ -1,8 +0,0 @@
-[Unit]
-Description=Terminal for weston user unit path
-
-[Path]
-PathExists=%t/wayland-0
-
-[Install]
-WantedBy=default.target
diff --git a/meta-app-framework/recipes-graphics/agl-desktop-config/files/user-weston-term.service b/meta-app-framework/recipes-graphics/agl-desktop-config/files/user-weston-term.service
deleted file mode 100644
index ad8b9583b..000000000
--- a/meta-app-framework/recipes-graphics/agl-desktop-config/files/user-weston-term.service
+++ /dev/null
@@ -1,12 +0,0 @@
-[Unit]
-Description=Terminal for weston user
-After=user-config.service
-Requires=user-config.service
-
-[Service]
-Type=simple
-ExecStart=/usr/bin/weston-terminal
-Restart=always
-
-[Install]
-WantedBy=multi-user.target