summaryrefslogtreecommitdiffstats
path: root/meta-app-framework
diff options
context:
space:
mode:
Diffstat (limited to 'meta-app-framework')
-rw-r--r--meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb4
-rw-r--r--meta-app-framework/recipes-core/af-main/af-main_1.0.inc3
2 files changed, 7 insertions, 0 deletions
diff --git a/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb b/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
index 2c9a7840c..0c9a78d3a 100644
--- a/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
+++ b/meta-app-framework/recipes-core/af-binder/af-binder_1.0.bb
@@ -16,10 +16,14 @@ SRC_URI = "${SRC_URI_git} \
"
SRCREV = "305d98f7b6db1a3207cc877bd2cda819e3b90656"
+PV = "master+git${SRCPV}"
+
S = "${WORKDIR}/git"
inherit cmake pkgconfig
+CFLAGS_append_agl-devel = " -DAGL_DEVEL"
+
pkg_postinst_${PN}() {
mkdir -p "$D${libdir}/afb"
}
diff --git a/meta-app-framework/recipes-core/af-main/af-main_1.0.inc b/meta-app-framework/recipes-core/af-main/af-main_1.0.inc
index f7d3bc8e1..1fd33adf4 100644
--- a/meta-app-framework/recipes-core/af-main/af-main_1.0.inc
+++ b/meta-app-framework/recipes-core/af-main/af-main_1.0.inc
@@ -15,6 +15,7 @@ SRC_URI = "${SRC_URI_git} \
"
SRCREV = "5cea66506dff09e8bdebbd623115ea103e87aba6"
+PV = "master+git${SRCPV}"
S = "${WORKDIR}/git"
@@ -24,3 +25,5 @@ afm_datadir = "/var/local/lib/${afm_name}"
afb_binding_dir = "${libdir}/afb"
systemd_units_root = "/usr/local/lib/systemd"
+CFLAGS_append_agl-devel = " -DAGL_DEVEL"
+