summaryrefslogtreecommitdiffstats
path: root/meta-app-framework
diff options
context:
space:
mode:
Diffstat (limited to 'meta-app-framework')
-rw-r--r--meta-app-framework/classes/aglwgt.bbclass105
-rw-r--r--meta-app-framework/recipes-core/af-main/af-main_git.bb4
-rw-r--r--meta-app-framework/recipes-core/af-main/af-main_git.inc2
3 files changed, 75 insertions, 36 deletions
diff --git a/meta-app-framework/classes/aglwgt.bbclass b/meta-app-framework/classes/aglwgt.bbclass
index 717bd7b90..d0f8055ae 100644
--- a/meta-app-framework/classes/aglwgt.bbclass
+++ b/meta-app-framework/classes/aglwgt.bbclass
@@ -27,26 +27,43 @@ EXTRA_OECMAKE_append_agl-ptest = " -DBUILD_TEST_WGT=TRUE"
OECMAKE_GENERATOR = "Unix Makefiles"
do_aglwgt_package() {
- cd ${B}
- ${S}/autobuild/agl/autobuild package BUILD_DIR=${B} DEST=${B} VERBOSE=TRUE || \
- ( ${S}/conf.d/autobuild/agl/autobuild package BUILD_DIR=${B} DEST=${B}/package VERBOSE=TRUE && \
- ( bbwarn "OBSOLETE: Your autobuild script should be located in :" ; \
- bbwarn "autobuild/agl/ from the project root source folder"; \
- bbwarn "and generate a .wgt file using wgtpack in the build"; \
- bbwarn "root folder calling:" ; \
- bbwarn "./autobuild/agl/autobuild package DEST=<BUILDDIR>" ; \
- bbwarn "See: https://wiki.automotivelinux.org/troubleshooting/app-recipes" \
- )
- ) ||
- ( bbwarn "OBSOLETE: You must have an autobuild script located in:" ; \
- bbwarn "autobuild/agl/ from the project root source folder"; \
- bbwarn "with filename autobuild which should generate"; \
- bbwarn "a .wgt file using wgtpack in the build"; \
- bbwarn "root folder calling:" ; \
- bbwarn "./autobuild/agl/autobuild package DEST=<BUILDDIR>" ; \
- bbwarn "Fix your package as it will not work within the SDK" ; \
- bbwarn "See: https://wiki.automotivelinux.org/troubleshooting/app-recipes"; \
- make package)
+
+ mkdir -p ${S}/build-test
+ mkdir -p ${S}/build-debug
+ mkdir -p ${S}/build-coverage
+
+ cd ${B}
+ ${S}/autobuild/agl/autobuild package BUILD_DIR=${B} DEST=${S}/widgets VERBOSE=TRUE || \
+ ( ${S}/conf.d/autobuild/agl/autobuild package BUILD_DIR=${B} DEST=${B}/package VERBOSE=TRUE && \
+ ( bbwarn "OBSOLETE: Your autobuild script should be located in :" ; \
+ bbwarn "autobuild/agl/ from the project root source folder"; \
+ bbwarn "and generate a .wgt file using wgtpack in the build"; \
+ bbwarn "root folder calling:" ; \
+ bbwarn "./autobuild/agl/autobuild package DEST=<BUILDDIR>" ; \
+ bbwarn "See: https://wiki.automotivelinux.org/troubleshooting/app-recipes" \
+ )
+ ) ||
+ ( bbwarn "OBSOLETE: You must have an autobuild script located in:" ; \
+ bbwarn "autobuild/agl/ from the project root source folder"; \
+ bbwarn "with filename autobuild which should generate"; \
+ bbwarn "a .wgt file using wgtpack in the build"; \
+ bbwarn "root folder calling:" ; \
+ bbwarn "./autobuild/agl/autobuild package DEST=<BUILDDIR>" ; \
+ bbwarn "Fix your package as it will not work within the SDK" ; \
+ bbwarn "See: https://wiki.automotivelinux.org/troubleshooting/app-recipes"; \
+ make package)
+
+ cd ${S}/build-test
+ ${S}/autobuild/agl/autobuild package-test BUILD_DIR=${S}/build-test DEST=${S}/widgets VERBOSE=TRUE || \
+ ( bbwarn "Target: package-test failed")
+
+ cd ${S}/build-debug
+ ${S}/autobuild/agl/autobuild package-debug BUILD_DIR=${S}/build-debug DEST=${S}/widgets VERBOSE=TRUE || \
+ ( bbwarn "Target: package-debug failed")
+
+ cd ${S}/build-coverage
+ ${S}/autobuild/agl/autobuild package-coverage BUILD_DIR=${S}/build-coverage DEST=${S}/widgets VERBOSE=TRUE || \
+ ( bbwarn "Target: package-coverage failed")
}
python () {
@@ -61,21 +78,39 @@ EXTRA_WGT_POSTINSTALL ?= ""
do_aglwgt_deploy() {
TEST_WGT="*-test.wgt"
+ DEBUG_WGT="*-debug.wgt"
+ COVERAGE_WGT="*-coverage.wgt"
if [ "${AGLWGT_AUTOINSTALL_${PN}}" = "0" ]
- then
- install -d ${D}/usr/AGL/apps/manualinstall
- install -m 0644 ${B}/*.wgt ${D}/usr/AGL/apps/manualinstall || \
- install -m 0644 ${B}/package/*.wgt ${D}/usr/AGL/apps/manualinstall
- else
- install -d ${D}/usr/AGL/apps/autoinstall
- install -m 0644 ${B}/*.wgt ${D}/usr/AGL/apps/autoinstall || \
- install -m 0644 ${B}/package/*.wgt ${D}/usr/AGL/apps/autoinstall
-
- if [ "$(find ${D}/usr/AGL/apps/autoinstall -name ${TEST_WGT})" ]
- then
- install -d ${D}/usr/AGL/apps/testwgt
- mv ${D}/usr/AGL/apps/autoinstall/*-test.wgt ${D}/usr/AGL/apps/testwgt
- fi
+ then
+ install -d ${D}/usr/AGL/apps/manualinstall
+ install -m 0644 ${B}/*.wgt ${D}/usr/AGL/apps/manualinstall || \
+ install -m 0644 ${B}/package/*.wgt ${D}/usr/AGL/apps/manualinstall
+ else
+ install -d ${D}/usr/AGL/apps/autoinstall
+ install -m 0644 ${B}/*.wgt ${D}/usr/AGL/apps/autoinstall || \
+ install -m 0644 ${B}/package/*.wgt ${D}/usr/AGL/apps/autoinstall
+
+ install -m 0644 ${S}/widgets/*.wgt ${D}/usr/AGL/apps/autoinstall || \
+ ( bbwarn "no package found in widget directory")
+
+ if [ "$(find ${D}/usr/AGL/apps/autoinstall -name ${TEST_WGT})" ]
+ then
+ install -d ${D}/usr/AGL/apps/testwgt
+ mv ${D}/usr/AGL/apps/autoinstall/*-test.wgt ${D}/usr/AGL/apps/testwgt
+ fi
+
+ if [ "$(find ${D}/usr/AGL/apps/autoinstall -name ${DEBUG_WGT})" ]
+ then
+ install -d ${D}/usr/AGL/apps/debugwgt
+ mv ${D}/usr/AGL/apps/autoinstall/*-debug.wgt ${D}/usr/AGL/apps/debugwgt
+ fi
+
+ if [ "$(find ${D}/usr/AGL/apps/autoinstall -name ${COVERAGE_WGT})" ]
+ then
+ install -d ${D}/usr/AGL/apps/coveragewgt
+ mv ${D}/usr/AGL/apps/autoinstall/*-coverage.wgt ${D}/usr/AGL/apps/coveragewgt
+ fi
+
fi
APP_FILES=""
@@ -97,6 +132,8 @@ EOF
FILES_${PN} += "/usr/AGL/apps/autoinstall/*.wgt \
/usr/AGL/apps/manualinstall/*.wgt \
/usr/AGL/apps/testwgt/*.wgt \
+ /usr/AGL/apps/debugwgt/*.wgt \
+ /usr/AGL/apps/coveragewgt/*.wgt \
${sysconfdir}/agl-postinsts/${POST_INSTALL_SCRIPT} \
"
diff --git a/meta-app-framework/recipes-core/af-main/af-main_git.bb b/meta-app-framework/recipes-core/af-main/af-main_git.bb
index 6e44c4959..66b93db5d 100644
--- a/meta-app-framework/recipes-core/af-main/af-main_git.bb
+++ b/meta-app-framework/recipes-core/af-main/af-main_git.bb
@@ -85,7 +85,9 @@ do_install_append_class-target() {
ln -sf ../afm-system-daemon.service ${D}${systemd_system_unitdir}/multi-user.target.wants/afm-system-daemon.service
ln -sf ../afm-system-daemon.socket ${D}${systemd_system_unitdir}/sockets.target.wants/afm-system-daemon.socket
fi
- echo "QT_WAYLAND_SHELL_INTEGRATION=ivi-shell" > ${D}${afm_confdir}/unit.env.d/qt-for-ivi-shell
+
+ DEFAULT_WM_SHELL="${@bb.utils.contains('DISTRO_FEATURES', 'agl-compositor', 'xdg-shell-v6', 'ivi-shell', d)}"
+ echo "QT_WAYLAND_SHELL_INTEGRATION=${DEFAULT_WM_SHELL}" > ${D}${afm_confdir}/unit.env.d/qt-shell
}
pkg_postinst_ontarget_${PN}() {
diff --git a/meta-app-framework/recipes-core/af-main/af-main_git.inc b/meta-app-framework/recipes-core/af-main/af-main_git.inc
index f61081555..b1cf7eb48 100644
--- a/meta-app-framework/recipes-core/af-main/af-main_git.inc
+++ b/meta-app-framework/recipes-core/af-main/af-main_git.inc
@@ -10,7 +10,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57"
SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/app-framework-main;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "c98333b595beb7858a4d3c17cd405dde2f79ce2e"
+SRCREV = "ab26673e4cef62736c15d5d7da02597d8382c65b"
PV = "${AGL_BRANCH}+git${SRCPV}"
S = "${WORKDIR}/git"