summaryrefslogtreecommitdiffstats
path: root/meta-app-framework
diff options
context:
space:
mode:
Diffstat (limited to 'meta-app-framework')
-rw-r--r--meta-app-framework/conf/layer.conf2
-rw-r--r--meta-app-framework/recipes-config/polkit-rule-agl-app/polkit-rule-agl-app.bb7
-rw-r--r--meta-app-framework/recipes-core/applaunchd/applaunchd_git.bb12
3 files changed, 12 insertions, 9 deletions
diff --git a/meta-app-framework/conf/layer.conf b/meta-app-framework/conf/layer.conf
index 0fe82784b..3af603703 100644
--- a/meta-app-framework/conf/layer.conf
+++ b/meta-app-framework/conf/layer.conf
@@ -9,5 +9,5 @@ BBFILE_COLLECTIONS += "meta-app-framework"
BBFILE_PATTERN_meta-app-framework = "^${LAYERDIR}/"
BBFILE_PRIORITY_meta-app-framework = "60"
-LAYERSERIES_COMPAT_meta-app-framework = "scarthgap"
+LAYERSERIES_COMPAT_meta-app-framework = "styhead"
LAYERDEPENDS_meta-app-framework = "core aglcore openembedded-layer"
diff --git a/meta-app-framework/recipes-config/polkit-rule-agl-app/polkit-rule-agl-app.bb b/meta-app-framework/recipes-config/polkit-rule-agl-app/polkit-rule-agl-app.bb
index 57dda7787..c4de20b38 100644
--- a/meta-app-framework/recipes-config/polkit-rule-agl-app/polkit-rule-agl-app.bb
+++ b/meta-app-framework/recipes-config/polkit-rule-agl-app/polkit-rule-agl-app.bb
@@ -2,9 +2,12 @@ SUMMARY = "Rule for agl-driver to control agl-app@ services"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+DEPENDS += "polkit"
+
SRC_URI = "file://50-agl-app.rules"
-DEPENDS += "polkit"
+S = "${WORKDIR}/sources"
+UNPACKDIR = "${S}"
inherit useradd features_check
REQUIRED_DISTRO_FEATURES = "polkit"
@@ -12,7 +15,7 @@ REQUIRED_DISTRO_FEATURES = "polkit"
do_install() {
install -m 700 -d ${D}${datadir}/polkit-1/rules.d
chown polkitd:root ${D}/${datadir}/polkit-1/rules.d
- install -m 0644 ${WORKDIR}/50-agl-app.rules ${D}${datadir}/polkit-1/rules.d
+ install -m 0644 ${UNPACKDIR}/50-agl-app.rules ${D}${datadir}/polkit-1/rules.d
}
USERADD_PACKAGES = "${PN}"
diff --git a/meta-app-framework/recipes-core/applaunchd/applaunchd_git.bb b/meta-app-framework/recipes-core/applaunchd/applaunchd_git.bb
index c1bafad8e..733070d24 100644
--- a/meta-app-framework/recipes-core/applaunchd/applaunchd_git.bb
+++ b/meta-app-framework/recipes-core/applaunchd/applaunchd_git.bb
@@ -45,15 +45,15 @@ SYSTEMD_SERVICE:${PN} = "applaunchd.service"
do_install:append() {
# Install generic template for all agl-app services
install -d ${D}${systemd_system_unitdir}
- install -m 644 ${WORKDIR}/applaunchd.service ${D}${systemd_system_unitdir}/
- install -m 644 ${WORKDIR}/agl-app@.service ${D}${systemd_system_unitdir}/
- install -m 644 ${WORKDIR}/agl-app-web@.service ${D}${systemd_system_unitdir}/
- install -m 644 ${WORKDIR}/agl-app-flutter@.service ${D}${systemd_system_unitdir}/
+ install -m 644 ${UNPACKDIR}/applaunchd.service ${D}${systemd_system_unitdir}/
+ install -m 644 ${UNPACKDIR}/agl-app@.service ${D}${systemd_system_unitdir}/
+ install -m 644 ${UNPACKDIR}/agl-app-web@.service ${D}${systemd_system_unitdir}/
+ install -m 644 ${UNPACKDIR}/agl-app-flutter@.service ${D}${systemd_system_unitdir}/
# Install individual sandboxing overrides/drop-ins to be used by apps
install -d ${D}${systemd_system_unitdir}/sandboxing
- install -m 644 ${WORKDIR}/no-network.conf ${D}${systemd_system_unitdir}/sandboxing/
- install -m 644 ${WORKDIR}/private-tmp.conf ${D}${systemd_system_unitdir}/sandboxing/
+ install -m 644 ${UNPACKDIR}/no-network.conf ${D}${systemd_system_unitdir}/sandboxing/
+ install -m 644 ${UNPACKDIR}/private-tmp.conf ${D}${systemd_system_unitdir}/sandboxing/
}
PACKAGE_BEFORE_PN += "${PN}-template-agl-app ${PN}-template-agl-app-web ${PN}-template-agl-app-flutter"