aboutsummaryrefslogtreecommitdiffstats
path: root/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker/0003-AmbSignalMapper-fix-can-interface-specification.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker/0003-AmbSignalMapper-fix-can-interface-specification.patch')
-rw-r--r--meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker/0003-AmbSignalMapper-fix-can-interface-specification.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker/0003-AmbSignalMapper-fix-can-interface-specification.patch b/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker/0003-AmbSignalMapper-fix-can-interface-specification.patch
new file mode 100644
index 000000000..3b37fbce3
--- /dev/null
+++ b/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker/0003-AmbSignalMapper-fix-can-interface-specification.patch
@@ -0,0 +1,28 @@
+From 14743846b201bec6607fcbe7727d8c71024cf920 Mon Sep 17 00:00:00 2001
+From: Petr Nechaev <petr.nechaev@cogentembedded.com>
+Date: Tue, 28 Jul 2015 18:39:11 +0300
+Subject: [PATCH 3/9] AmbSignalMapper: fix can interface specification
+
+---
+ tools/AmbSignalMapper/lib/Intel/IviPoc/templates/CMakeLists.txt | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/tools/AmbSignalMapper/lib/Intel/IviPoc/templates/CMakeLists.txt b/tools/AmbSignalMapper/lib/Intel/IviPoc/templates/CMakeLists.txt
+index f5bfee9..4d1dd05 100644
+--- a/tools/AmbSignalMapper/lib/Intel/IviPoc/templates/CMakeLists.txt
++++ b/tools/AmbSignalMapper/lib/Intel/IviPoc/templates/CMakeLists.txt
+@@ -10,9 +10,9 @@ set(PLUGIN_INSTALL_PATH "${LIB_INSTALL_DIR}/automotive-message-broker")
+ set (CMAKE_INSTALL_PREFIX /usr)
+
+ # check that CAN interface is specified and use vcan0 by default
+-if(NOT DEFINED ${DEFAULT_CAN_INTERFACE})
++if(NOT DEFINED DEFAULT_CAN_INTERFACE)
+ set(DEFAULT_CAN_INTERFACE "vcan0")
+-endif(NOT DEFINED ${DEFAULT_CAN_INTERFACE})
++endif(NOT DEFINED DEFAULT_CAN_INTERFACE)
+
+ if(CMAKE_BUILD_TYPE MATCHES DEBUG)
+ message("debug mode")
+--
+1.9.1
+