summaryrefslogtreecommitdiffstats
path: root/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.bb')
-rw-r--r--meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.bb b/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.bb
index dee6f5980..fb1cb774f 100644
--- a/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.bb
+++ b/meta-ivi-common/recipes-automotive/automotive-message-broker/automotive-message-broker_git.bb
@@ -38,6 +38,19 @@ do_install_append() {
if [ "${@bb.utils.contains('PACKAGECONFIG', 'use_gps', 'use_gps', '', d)}" = "use_gps" ]; then
install -m 0644 ${WORKDIR}/gps ${D}/${sysconfdir}/ambd/plugins.d
fi
+
+ # Grmbl - heck gotta fix library installations ?!? WTF !
+ # GO FIX YOUR INSTALLATION ROUTINES PLEASE. ;) (jsmoeller)
+ # HACK-ALARM:
+ ls -alh ${D}${libdir}
+ if test -e ${D}${libdir}/libamb-qt.so -a ! -L ${D}${libdir}/libamb-qt.so ; then
+ mv ${D}${libdir}/libamb-qt.so ${D}${libdir}/libamb-qt.so.0
+ ln -sf libamb-qt.so.0 ${D}${libdir}/libamb-qt.so
+ fi
+ if test -e ${D}${libdir}/libamb-plugins-common.so -a ! -L ${D}${libdir}/libamb-plugins-common.so ; then
+ mv ${D}${libdir}/libamb-plugins-common.so ${D}${libdir}/libamb-plugins-common.so.0
+ ln -sf libamb-plugins-common.so.0 ${D}${libdir}/libamb-plugins-common.so
+ fi
}
FILES_${PN} += " ${systemd_unitdir}/ambd.service \