aboutsummaryrefslogtreecommitdiffstats
path: root/meta-netboot/recipes-core/images/initramfs-netboot-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-netboot/recipes-core/images/initramfs-netboot-image.bb')
-rw-r--r--meta-netboot/recipes-core/images/initramfs-netboot-image.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-netboot/recipes-core/images/initramfs-netboot-image.bb b/meta-netboot/recipes-core/images/initramfs-netboot-image.bb
new file mode 100644
index 000000000..8b461e555
--- /dev/null
+++ b/meta-netboot/recipes-core/images/initramfs-netboot-image.bb
@@ -0,0 +1,19 @@
+# Netboot initramfs image.
+DESCRIPTION = "Netboot initrd image"
+
+PACKAGE_INSTALL = "initramfs-netboot busybox base-passwd ${ROOTFS_BOOTSTRAP_INSTALL}"
+
+# Do not pollute the initrd image with rootfs features
+IMAGE_FEATURES = ""
+
+export IMAGE_BASENAME = "initramfs-netboot-image"
+IMAGE_LINGUAS = ""
+
+LICENSE = "MIT"
+
+IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
+inherit core-image
+
+IMAGE_ROOTFS_SIZE = "8192"
+
+BAD_RECOMMENDATIONS += "busybox-syslog"