summaryrefslogtreecommitdiffstats
path: root/meta-netboot
diff options
context:
space:
mode:
Diffstat (limited to 'meta-netboot')
-rw-r--r--meta-netboot/classes/netboot.bbclass4
-rw-r--r--meta-netboot/recipes-core/images/initramfs-netboot-image.bb2
2 files changed, 3 insertions, 3 deletions
diff --git a/meta-netboot/classes/netboot.bbclass b/meta-netboot/classes/netboot.bbclass
index 3440914a5..c74c10510 100644
--- a/meta-netboot/classes/netboot.bbclass
+++ b/meta-netboot/classes/netboot.bbclass
@@ -17,9 +17,9 @@ python () {
d.setVar("INITRAMFS_IMAGE","initramfs-netboot-image")
if (d.getVar("KERNEL_IMAGETYPE",True) == "uImage"):
# case for "old" u-boot images, like Porter board
- d.setVar("INITRAMFS_FSTYPES_pn-initramfs-netboot-image", "ext4.gz.u-boot");
+ d.setVar("NETBOOT_FSTYPES", "ext4.gz.u-boot");
else:
# case for new u-boot images which don't require uImage format
- d.setVar("INITRAMFS_FSTYPES_pn-initramfs-netboot-image", "ext4.gz");
+ d.setVar("NETBOOT_FSTYPES", "ext4.gz");
}
diff --git a/meta-netboot/recipes-core/images/initramfs-netboot-image.bb b/meta-netboot/recipes-core/images/initramfs-netboot-image.bb
index b9c8d2f75..cc6bc6753 100644
--- a/meta-netboot/recipes-core/images/initramfs-netboot-image.bb
+++ b/meta-netboot/recipes-core/images/initramfs-netboot-image.bb
@@ -11,7 +11,7 @@ IMAGE_LINGUAS = ""
LICENSE = "MIT"
-IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
+IMAGE_FSTYPES = "${NETBOOT_FSTYPES}"
inherit core-image
IMAGE_ROOTFS_SIZE = "8192"