summaryrefslogtreecommitdiffstats
path: root/meta-security
diff options
context:
space:
mode:
Diffstat (limited to 'meta-security')
-rw-r--r--meta-security/recipes-core/base-files/base-files_%.bbappend4
-rw-r--r--meta-security/recipes-core/packagegroups/packagegroup-security-framework.bb2
-rw-r--r--meta-security/recipes-core/systemd/systemd_%.bbappend2
-rw-r--r--meta-security/recipes-security/cynara/cynara.inc4
-rw-r--r--meta-security/recipes-security/smack/smack-userspace_git.bb27
5 files changed, 6 insertions, 33 deletions
diff --git a/meta-security/recipes-core/base-files/base-files_%.bbappend b/meta-security/recipes-core/base-files/base-files_%.bbappend
index 7a37eb9dc..a6af1821b 100644
--- a/meta-security/recipes-core/base-files/base-files_%.bbappend
+++ b/meta-security/recipes-core/base-files/base-files_%.bbappend
@@ -40,8 +40,8 @@ EOF
# via postinst. This is much easier to use with bitbake, too:
# - no need to maintain a patched rpm
# - works for directories which are not packaged by default when empty
-RDEPENDS_${PN}_append_with-lsm-smack = " smack-userspace"
-DEPENDS_append_with-lsm-smack = " smack-userspace-native"
+RDEPENDS_${PN}_append_with-lsm-smack = " smack"
+DEPENDS_append_with-lsm-smack = " smack-native"
pkg_postinst_${PN}_with-lsm-smack() {
#!/bin/sh -e
diff --git a/meta-security/recipes-core/packagegroups/packagegroup-security-framework.bb b/meta-security/recipes-core/packagegroups/packagegroup-security-framework.bb
index c728da3b9..b52e18d4e 100644
--- a/meta-security/recipes-core/packagegroups/packagegroup-security-framework.bb
+++ b/meta-security/recipes-core/packagegroups/packagegroup-security-framework.bb
@@ -8,7 +8,7 @@ inherit packagegroup
#
# Cynara does not have a hard dependency on Smack security,
# but is meant to be used with it. security-manager however
-# links against smack-userspace and expects Smack to be active,
+# links against smack and expects Smack to be active,
# so we do not have any choice.
#
# Without configuration, security-manager is not usable. We use
diff --git a/meta-security/recipes-core/systemd/systemd_%.bbappend b/meta-security/recipes-core/systemd/systemd_%.bbappend
index bea5a3731..65e28f9de 100644
--- a/meta-security/recipes-core/systemd/systemd_%.bbappend
+++ b/meta-security/recipes-core/systemd/systemd_%.bbappend
@@ -53,7 +53,7 @@ install_file() {
# /var/tmp point into /var/volatile (tmpfs) and get created anew during
# startup. We set these permissions directly after creating them via
# /etc/tmpfiles.d/00-create-volatile.conf
-RDEPENDS_${PN}_append_with-lsm-smack = " smack-userspace"
+RDEPENDS_${PN}_append_with-lsm-smack = " smack"
do_install_append_with-lsm-smack() {
install_file ${D}${systemd_unitdir}/system/systemd-tmpfiles-setup.service.d/smack.conf <<EOF
[Service]
diff --git a/meta-security/recipes-security/cynara/cynara.inc b/meta-security/recipes-security/cynara/cynara.inc
index 0e823edcc..1e80b6163 100644
--- a/meta-security/recipes-security/cynara/cynara.inc
+++ b/meta-security/recipes-security/cynara/cynara.inc
@@ -113,8 +113,8 @@ FILES_${PN} += "${systemd_unitdir}/system"
# the postinst completes, but that is a general problem. It gets
# avoided entirely when calling this script while building the
# rootfs.
-RDEPENDS_${PN}_append_with-lsm-smack = " smack-userspace"
-DEPENDS_append_with-lsm-smack = " smack-userspace-native"
+RDEPENDS_${PN}_append_with-lsm-smack = " smack"
+DEPENDS_append_with-lsm-smack = " smack-native"
CHSMACK_with-lsm-smack = "chsmack"
CHSMACK = "true"
pkg_postinst_${PN} () {
diff --git a/meta-security/recipes-security/smack/smack-userspace_git.bb b/meta-security/recipes-security/smack/smack-userspace_git.bb
deleted file mode 100644
index aa6d5fa6f..000000000
--- a/meta-security/recipes-security/smack/smack-userspace_git.bb
+++ /dev/null
@@ -1,27 +0,0 @@
-DESCRIPTION = "Selection of tools for developers working with Smack"
-HOMEPAGE = "https://github.com/smack-team/smack"
-SECTION = "Security/Access Control"
-LICENSE = "LGPL-2.1"
-
-# Alias needed to satisfy dependencies in other recipes.
-# This recipe itself cannot be named "smack" because that
-# would conflict with the "smack" override.
-PROVIDES = "smack"
-RPROVIDES_${PN} += "smack"
-
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
-PV = "1.2.0+git${SRCPV}"
-SRCREV = "d82bac7dac69823fd40015dffad1a128505a2258"
-SRC_URI += "git://github.com/smack-team/smack.git;protocol=https;branch=v1.2.x"
-S = "${WORKDIR}/git"
-
-inherit autotools
-
-BBCLASSEXTEND = "native"
-
-# Fix copied from meta-tizen.
-do_configure_prepend() {
- export ac_cv_prog_DOXYGEN=""
- sed -i 's@systemd_new=no@systemd_new=yes@' ${S}/configure.ac
- sed -i '/PKG_CHECK_MODULES(/,/)/{s/b/r/p;d}' ${S}/configure.ac
-}
0'>370 371 372 373 374 375 376 377 378 379 380 381 382 383 384 385 386 387 388 389 390 391 392 393 394 395 396 397 398 399 400 401 402 403 404 405 406 407 408 409 410 411 412 413 414 415 416 417 418 419 420 421 422 423 424 425 426 427 428 429 430 431 432 433 434 435 436