summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/meta-renesas/recipes-kernel/ @media only all and (prefers-color-scheme: dark) { .highlight .hll { background-color: #49483e } .highlight .c { color: #75715e } /* Comment */ .highlight .err { color: #960050; background-color: #1e0010 } /* Error */ .highlight .k { color: #66d9ef } /* Keyword */ .highlight .l { color: #ae81ff } /* Literal */ .highlight .n { color: #f8f8f2 } /* Name */ .highlight .o { color: #f92672 } /* Operator */ .highlight .p { color: #f8f8f2 } /* Punctuation */ .highlight .ch { color: #75715e } /* Comment.Hashbang */ .highlight .cm { color: #75715e } /* Comment.Multiline */ .highlight .cp { color: #75715e } /* Comment.Preproc */ .highlight .cpf { color: #75715e } /* Comment.PreprocFile */ .highlight .c1 { color: #75715e } /* Comment.Single */ .highlight .cs { color: #75715e } /* Comment.Special */ .highlight .gd { color: #f92672 } /* Generic.Deleted */ .highlight .ge { font-style: italic } /* Generic.Emph */ .highlight .gi { color: #a6e22e } /* Generic.Inserted */ .highlight .gs { font-weight: bold } /* Generic.Strong */ .highlight .gu { color: #75715e } /* Generic.Subheading */ .highlight .kc { color: #66d9ef } /* Keyword.Constant */ .highlight .kd { color: #66d9ef } /* Keyword.Declaration */ .highlight .kn { color: #f92672 } /* Keyword.Namespace */ .highlight .kp { color: #66d9ef } /* Keyword.Pseudo */ .highlight .kr { color: #66d9ef } /* Keyword.Reserved */ .highlight .kt { color: #66d9ef } /* Keyword.Type */ .highlight .ld { color: #e6db74 } /* Literal.Date */ .highlight .m { color: #ae81ff } /* Literal.Number */ .highlight .s { color: #e6db74 } /* Literal.String */ .highlight .na { color: #a6e22e } /* Name.Attribute */ .highlight .nb { color: #f8f8f2 } /* Name.Builtin */ .highlight .nc { color: #a6e22e } /* Name.Class */ .highlight .no { color: #66d9ef } /* Name.Constant */ .highlight .nd { color: #a6e22e } /* Name.Decorator */ .highlight .ni { color: #f8f8f2 } /* Name.Entity */ .highlight .ne { color: #a6e22e } /* Name.Exception */ .highlight .nf { color: #a6e22e } /* Name.Function */ .hig
FILESEXTRAPATHS_prepend := "${THISDIR}/linux:"

# Enable support for TP-Link TL-W722N USB Wifi adapter and RTL2832U DVB USB and USB Audio
# adapter.
SRC_URI += " file://disable_delay_printk.patch \
             file://cfg_mac_80211.cfg \
             file://ath9k_htc.cfg \
             file://rtl_sdr.cfg \
             file://usbaudio.cfg \
             file://ra2x00.cfg \
             file://0001-media-r820t-do-not-double-free-fe-tuner_priv-in-r820.patch \
             file://0002-media-r820t-remove-redundant-initializations-in-r820.patch \
             file://0003-media-r820t-avoid-potential-memcpy-buffer-overflow-i.patch \
             file://hciattach.cfg \
             file://pppd-rcar.cfg \
            "

KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/ath9k_htc.cfg ${WORKDIR}/rtl_sdr.cfg"

SRC_URI_append_agl-porter-hibernate = " file://hibernation/0001-Add-Hibernation-kernel-base-code.patch \
                                        file://hibernation/0002-Add-Hibernation-arch-code-Only-R-CAR-M2W.patch \
                                        file://hibernation/0003-Add-sata-hibernation-code.patch \
                                        file://hibernation/0004-Add-firmware-hibernation-code.patch \
                                        file://hibernation/0005-Add-rcar-dma-hibernation-code.patch \
                                        file://hibernation/0006-Add-rcar-du-hibernation-code.patch \
                                        file://hibernation/0007-Add-rcar-i2c-hibernation-code.patch \
                                        file://hibernation/0008-Add-rcar-mmc-hibernation-code.patch \
                                        file://hibernation/0009-Add-hibernation-store-area.patch \
                                        file://hibernation/0010-Add-rcar-eth-hibernation-code.patch \
                                        file://hibernation/0011-Add-rcar-pci-hibernation-code.patch \
                                        file://hibernation/0012-Add-rcar-gpio-hibernation-code.patch \
                                        file://hibernation/0013-Add-rcar-spi-hibernation-code.patch \
                                        file://hibernation/0014-Add-rcar-sci-hibernation-code.patch \ 
                                        file://hibernation/0015-Add-rcar-usbphy-hibernation-code.patch \
                                        file://hibernation/0001-Add-shdmac-hibernation-code.patch \
                                        file://hibernation/0002-Fix-Black-blink-correction-of-display.patch \
                                        file://hibernation/0003-Add-hibernation-image-area.patch \
                                        file://hibernation/hibernation.cfg \
                                       "

KERNEL_CONFIG_FRAGMENTS_append_agl-porter-hibernate += " ${WORKDIR}/hibernation/hibernation.cfg"

# file comes out of  meta-agl-bsp/recipes-kernel/linux/linux_%.bbappend
KERNEL_CONFIG_FRAGMENTS_append = " ${WORKDIR}/can-bus.cfg"