summaryrefslogtreecommitdiffstats
path: root/meta-agl-bsp/recipes-bsp/u-boot/u-boot-ota_2015.07.bb
blob: 7ef3cacd4ed08fd85ec7a6e64fbc800656cbc012 (plain)
1
@media only all and (prefers-color-scheme: dark) {
.highlight .hll { background-color: #49483e }
.highlight .c { color: #75715e } /* Comment */
.highlight .err { color: #960050; background-color: #1e0010 } /* Error */
.highlight .k { color: #66d9ef } /* Keyword */
.highlight .l { color: #ae81ff } /* Literal */
.highlight .n { color: #f8f8f2 } /* Name */
.highlight .o { color: #f92672 } /* Operator */
.highlight .p { color: #f8f8f2 } /* Punctuation */
.highlight .ch { color: #75715e } /* Comment.Hashbang */
.highlight .cm { color: #75715e } /* Comment.Multiline */
.highlight .cp { color: #75715e } /* Comment.Preproc */
.highlight .cpf { color: #75715e } /* Comment.PreprocFile */
.highlight .c1 { color: #75715e } /* Comment.Single */
.highlight .cs { color: #75715e } /* Comment.Special */
.highlight .gd { color: #f92672 } /* Generic.Deleted */
.highlight .ge { font-sty
include recipes-bsp/u-boot/u-boot.inc
DEPENDS += "dtc-native"

LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://Licenses/README;md5=0507cd7da8e7ad6d6701926ec9b84c95"

# This revision corresponds to the tag "v2015.07"
# We use the revision in order to avoid having to fetch it from the
# repo during parse
SRCREV = "baba2f57e8f4ed3fa67fe213d22da0de5e00f204"

SRC_URI = "\
    git://git.denx.de/u-boot.git;branch=master \
    file://0001-Set-up-environment-for-OSTree-integration.patch \
    file://0002-Replace-wraps-with-built-in-code-to-remove-dependenc.patch \
    file://0001-fixup-build-with-gcc6.patch \
    file://0002-fixup-build-with-gcc7.patch \
"
S = "${WORKDIR}/git"

PV = "v2015.07+git${SRCPV}"

EXTRA_OEMAKE_append = " KCFLAGS=-fgnu89-inline "
EXTRA_OEMAKE_append_qemux86 = " BUILD_ROM=y"
EXTRA_OEMAKE_append_qemux86-64 = " BUILD_ROM=y"

UBOOT_SUFFIX = "bin"
UBOOT_SUFFIX_qemux86 = "rom"
UBOOT_SUFFIX_qemux86-64 = "rom"