summaryrefslogtreecommitdiffstats
path: root/meta-pipewire/recipes-multimedia/wireplumber/wireplumber-config-agl_git.bb
blob: 86d77257d285013d5d9c600326159a532a98756a (plain)

@media only all and (prefers-color-scheme: dark) {
.highlight .hll { background-color: #49483e }
.highlight .c { color: #75715e } /* Comment */
.highlight .err { color: #960050; background-color: #1e0010 } /* Error */
.highlight .k { color: #66d9ef } /* Keyword */
.highlight .l { color: #ae81ff } /* Literal */
.highlight .n { color: #f8f8f2 } /* Name */
.highlight .o { color: #f92672 } /* Operator */
.highlight .p { color: #f8f8f2 } /* Punctuation */
.highlight .ch { color: #75715e } /* Comment.Hashbang */
.highlight .cm { color: #75715e } /* Comment.Multiline */
.highlight .cp { color: #75715e } /* Comment.Preproc */
.highlight .cpf { color: #75715e } /* Comment.PreprocFile */
.highlight .c1 { color: #75715e } /* Comment.Single */
.highlight .cs { color: #75715e } /* Comment.Special */
.highlight .gd { color: #f92672 } /* Generic.Deleted */
.highlight .ge { font-style: italic } /* Generic.Emph */
.highlight .gi { color: #a6e22e } /* Generic.Inserted */
.highlight .gs { font-weight: bold } /* Generic.Strong */
.highlight .gu { color: #75715e } /* Generic.Subheading */
.highlight .kc { color: #66d9ef } /* Keyword.Constant */
.highlight .kd { color: #66d9ef } /* Keyword.Declaration */
.highlight .kn { color: #f92672 } /* Keyword.Namespace */
.highlight .kp { color: #66d9ef } /* Keyword.Pseudo */
.highlight .kr { color: #66d9ef } /* Keyword.Reserved */
.highlight .kt { color: #66d9ef } /* Keyword.Typ
require conf/include/agl_rcar.inc
SOC_FAMILY = "r8a77990"
BOARD_NAME = "ebisu"

DTB_SUFFIX = "r8a77990-ebisu"

DISTRO_FEATURES_remove = " use_eva_pkg"

# Configuration for USB 3.0
MACHINE_FEATURES_append = " usb3"

IMAGE_INSTALL_append = " gstreamer1.0-omx gstreamer1.0-plugin-vspfilter"
IMAGE_INSTALL_append = " kernel-module-mmngr kernel-module-mmngrbuf kernel-module-uvcs-drv kernel-module-vspmif"
an> = "multimedia" LICENSE = "MIT" LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302" SRC_URI = "\ file://00-functions.lua \ file://00-spa-libs.lua \ file://10-default-policy.lua \ file://30-alsa-monitor.lua \ file://30-bluez-monitor.lua \ file://99-load-modules.lua \ file://wireplumber.conf \ file://wireplumber-bluetooth.conf \ " PACKAGE_ARCH = "${MACHINE_ARCH}" do_configure[noexec] = "1" do_compile[noexec] = "1" do_install_append() { config_dir="${D}${sysconfdir}/wireplumber/config.lua.d/" dbus_config_dir="${D}${sysconfdir}/dbus-1/system.d/" install -d ${config_dir} install -m 0644 ${WORKDIR}/00-functions.lua ${config_dir} install -m 0644 ${WORKDIR}/00-spa-libs.lua ${config_dir} install -m 0644 ${WORKDIR}/10-default-policy.lua ${config_dir} install -m 0644 ${WORKDIR}/30-alsa-monitor.lua ${config_dir} install -m 0644 ${WORKDIR}/30-bluez-monitor.lua ${config_dir} install -m 0644 ${WORKDIR}/99-load-modules.lua ${config_dir} install -m 0644 ${WORKDIR}/wireplumber.conf ${D}${sysconfdir}/wireplumber/ install -d ${dbus_config_dir} install -m 0644 ${WORKDIR}/wireplumber-bluetooth.conf ${dbus_config_dir} } FILES_${PN} += "\ ${sysconfdir}/wireplumber/* \ " CONFFILES_${PN} += "\ ${sysconfdir}/wireplumber/* \ " RPROVIDES_${PN} += "virtual/wireplumber-config"