aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Lawrence <stephen.lawrence@renesas.com>2017-02-03 19:04:27 +0000
committerKhiem Nguyen <khiem.nguyen.xt@renesas.com>2017-03-27 03:35:16 +0000
commit4979e05406c77524cf90b308ce4bf2a72032ee65 (patch)
tree0def1a942c375205f67e2eff3bb8725f797b0870
parented74f73cbb6194e88e1ec3502e58e87adf38ed5e (diff)
rcar-gen3: ppp: Add patches to fix build with 4.8/4.9 kernel headersRenesas-Yocto-v2.17.0
Carry patches to fix poky meta ppp build with 4.9 kernel used in Yocto BSP v2.16. Fixes are in poky master branch but have not yet been migrated to krogoth. Carry them in a bbappend until that happens. (From Poky rev: 81339d0113a9aafd4cce878f30071a3c1a8e2dcf 8d3a2726f6725977d83dc71a5cd08ba9a062001b) Change-Id: Ibb9a0569ceafe3758cf23fb18647a8795e6c8b92 Signed-off-by: Stephen Lawrence <stephen.lawrence@renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
-rw-r--r--meta-rcar-gen3/recipes-connectivity/ppp/ppp/0001-ppp-Remove-unneeded-include.patch43
-rw-r--r--meta-rcar-gen3/recipes-connectivity/ppp/ppp/ppp-fix-building-with-linux-4.8.patch44
-rw-r--r--meta-rcar-gen3/recipes-connectivity/ppp/ppp_2.4.7.bbappend6
3 files changed, 93 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-connectivity/ppp/ppp/0001-ppp-Remove-unneeded-include.patch b/meta-rcar-gen3/recipes-connectivity/ppp/ppp/0001-ppp-Remove-unneeded-include.patch
new file mode 100644
index 0000000..a32f89f
--- /dev/null
+++ b/meta-rcar-gen3/recipes-connectivity/ppp/ppp/0001-ppp-Remove-unneeded-include.patch
@@ -0,0 +1,43 @@
+commit cd90fd147844a0cfec101f1e2db7a3c59d236621
+Author: Jussi Kukkonen <jussi.kukkonen@intel.com>
+Date: Wed Dec 28 14:11:22 2016 +0200
+
+pppol2tp plugin: Remove unneeded include
+
+The include is not required and will break compile on musl libc with
+
+| In file included from pppol2tp.c:34:0:
+| /usr/include/linux/if.h:97:2: error: expected identifier before numeric constant
+| IFF_LOWER_UP = 1<<16, /* __volatile__ */
+
+Patch originally from Khem Raj.
+
+Upstream-Status: Pending [https://github.com/paulusmack/ppp/issues/73]
+Signed-off-by: Jussi Kukkonen <jussi.kukkonen@intel.com>
+
+diff --git a/pppd/plugins/pppol2tp/openl2tp.c b/pppd/plugins/pppol2tp/openl2tp.c
+index 9643b96..458316b 100644
+--- a/pppd/plugins/pppol2tp/openl2tp.c
++++ b/pppd/plugins/pppol2tp/openl2tp.c
+@@ -47,7 +47,6 @@
+ #include <linux/if_ether.h>
+ #include <linux/ppp_defs.h>
+ #include <linux/if_ppp.h>
+-#include <linux/if_pppox.h>
+ #include <linux/if_pppol2tp.h>
+
+ #include "l2tp_event.h"
+diff --git a/pppd/plugins/pppol2tp/pppol2tp.c b/pppd/plugins/pppol2tp/pppol2tp.c
+index 0e28606..4f6d98c 100644
+--- a/pppd/plugins/pppol2tp/pppol2tp.c
++++ b/pppd/plugins/pppol2tp/pppol2tp.c
+@@ -46,7 +46,6 @@
+ #include <linux/if_ether.h>
+ #include <linux/ppp_defs.h>
+ #include <linux/if_ppp.h>
+-#include <linux/if_pppox.h>
+ #include <linux/if_pppol2tp.h>
+
+ /* should be added to system's socket.h... */
+---
+
diff --git a/meta-rcar-gen3/recipes-connectivity/ppp/ppp/ppp-fix-building-with-linux-4.8.patch b/meta-rcar-gen3/recipes-connectivity/ppp/ppp/ppp-fix-building-with-linux-4.8.patch
new file mode 100644
index 0000000..f77b0de
--- /dev/null
+++ b/meta-rcar-gen3/recipes-connectivity/ppp/ppp/ppp-fix-building-with-linux-4.8.patch
@@ -0,0 +1,44 @@
+From 3da19af53e2eee2e77b456cfbb9d633b06656d38 Mon Sep 17 00:00:00 2001
+From: Jackie Huang <jackie.huang@windriver.com>
+Date: Thu, 13 Oct 2016 13:41:43 +0800
+Subject: [PATCH] ppp: fix building with linux-4.8
+
+Fix a build error when using the linux-4.8 headers that results in:
+
+In file included from pppoe.h:87:0,
+ from plugin.c:29:
+../usr/include/netinet/in.h:211:8: note: originally defined here
+ struct in6_addr
+ ^~~~~~~~
+In file included from ../usr/include/linux/if_pppol2tp.h:20:0,
+ from ../usr/include/linux/if_pppox.h:26,
+ from plugin.c:52:
+../usr/include/linux/in6.h:49:8: error: redefinition of 'struct sockaddr_in6'
+ struct sockaddr_in6 {
+ ^~~~~~~~~~~~
+
+Upstream-Status: Submitted [1]
+
+[1] https://github.com/paulusmack/ppp/pull/69
+
+Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
+---
+ pppd/plugins/rp-pppoe/pppoe.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/pppd/plugins/rp-pppoe/pppoe.h b/pppd/plugins/rp-pppoe/pppoe.h
+index 9ab2eee..96d2794 100644
+--- a/pppd/plugins/rp-pppoe/pppoe.h
++++ b/pppd/plugins/rp-pppoe/pppoe.h
+@@ -84,7 +84,7 @@ typedef unsigned long UINT32_t;
+ #include <linux/if_ether.h>
+ #endif
+
+-#include <netinet/in.h>
++#include <linux/in.h>
+
+ #ifdef HAVE_NETINET_IF_ETHER_H
+ #include <sys/types.h>
+--
+2.8.3
+
diff --git a/meta-rcar-gen3/recipes-connectivity/ppp/ppp_2.4.7.bbappend b/meta-rcar-gen3/recipes-connectivity/ppp/ppp_2.4.7.bbappend
new file mode 100644
index 0000000..5aa46fb
--- /dev/null
+++ b/meta-rcar-gen3/recipes-connectivity/ppp/ppp_2.4.7.bbappend
@@ -0,0 +1,6 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+
+SRC_URI_append = " \
+ file://ppp-fix-building-with-linux-4.8.patch \
+ file://0001-ppp-Remove-unneeded-include.patch \
+"