aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhang Nguyen <khang.nguyen.xw@renesas.com>2019-07-18 13:31:22 +0700
committerDuy Dang <duy.dang.yw@renesas.com>2019-09-23 11:17:05 +0700
commit538a6f55e7860c8cd4ce883a15ea589d631ad703 (patch)
treec8571978dcf15dca76e516a5b2e94d8bdbf069d0
parent2b6ce4eac8ae826fe3a0a2d2639b8a5ae6293903 (diff)
rcar-gen3: optee-os: Fix git configuration issue in do_configure
Since v3.15.0, the optee-os recipe does a cherry-pick in do_configure, if the git is not configured, the do_configure will fail and breaks the build. This adds '-n' flag to cherry-pick command to avoid the above issue. Signed-off-by: Khang Nguyen <khang.nguyen.xw@renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com> Change-Id: I6448b57b4a9609599497f3a35ada5c777015a7f0
-rw-r--r--meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb b/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
index 5f69c7d..553174b 100644
--- a/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
+++ b/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
@@ -45,7 +45,7 @@ EXTRA_OEMAKE = "-e MAKEFLAGS="
do_configure() {
git -C ${WORKDIR}/git_official checkout -B official 3.1.0
- git -C ${WORKDIR}/git_official cherry-pick ${SRCREV_officialgit}
+ git -C ${WORKDIR}/git_official cherry-pick -n ${SRCREV_officialgit}
cp -rn ${WORKDIR}/git_official/core/lib/libtomcrypt ${B}/core/lib/.
}