aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDuy Dang <duy.dang.yw@rvc.renesas.com>2019-01-21 10:16:30 +0700
committerDuy Dang <duy.dang.yw@renesas.com>2019-04-02 09:31:34 +0700
commit5df4c994040171bd7bf13c625b1fef295d1e9c9c (patch)
treefca3f6e61e1c7501adb84e9a064bd5c936540327
parentaa3c60e8241bff75503eb2b52a3ea59115b0176a (diff)
rcar-gen3: gles-module: Fix wrong condition
The condition "if [ <true/false> ]" always returns true, because it checks for non-empty string. Fix it by removing the brackets. Change-Id: Ib9fe24e6a8ef3f93e9ed17d118775b54765ae5bb Signed-off-by: Duy Dang <duy.dang.yw@renesas.com> Signed-off-by: Khang Nguyen <khang.nguyen.xw@renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
-rw-r--r--meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb b/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb
index ba425b9..29f25c9 100644
--- a/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb
+++ b/meta-rcar-gen3/recipes-graphics/gles-module/gles-user-module.bb
@@ -80,7 +80,7 @@ do_install() {
fi
# Install systemd service
- if [ ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)} ]; then
+ if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)} ; then
install -d ${D}${systemd_system_unitdir}/
install -m 644 ${WORKDIR}/rc.pvr.service ${D}${systemd_system_unitdir}/
install -d ${D}${exec_prefix}/bin