aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThuy Tran <thuy.tran.xh@rvc.renesas.com>2017-11-01 14:12:02 +0700
committerThuy Tran <thuy.tran.xh@rvc.renesas.com>2017-11-24 20:15:58 +0700
commit7acbf5e2f99c59478adbc73c6a40d314589a3009 (patch)
tree5f1af59a482934b849840430fb05a949ef3e2b27
parent149da3d318e971d9abb03ded59da7727cffaec08 (diff)
rcar-gen3: run-postinsts: WORKAROUND to fix dependency failed for serial gettyRenesas-Yocto-v2.23.1
This commit modifies recipe to fix this issue by following Poky commit. Title: run-postinsts: do not reload daemon configuration Auther: Max Krummenacher <max.oss.09@gmail.com> Commit: 24a4b7114bf937ffb38b7696e75cf6ea917026a7 In case a systemd service disables itself while init is still in its boot sequence the reloading of the service files can be problematic. In that case: It seems that systemd looses the state of .device units, and some services depend on such units (namely serial consoles such as serial-getty@ttymxc0.service). As a result no getty is spawned on the affected serial tty. After a power-cycle the second boot (which does not disable services) succeeds. The following sequence shows this problem: | Jan 09 16:36:28 apalis-t30 systemctl[162]: Removed /etc/systemd/system/sysinit.target.wants/run-postinsts.service. | Jan 09 16:36:28 apalis-t30 systemd[1]: Reloading. | ... | And then the failing one: | Feb 22 15:33:15 apalis-t30 systemd[1]: dev-ttyS0.device: Job dev-ttyS0.device/start timed out. | Feb 22 15:33:15 apalis-t30 systemd[1]: Timed out waiting for device dev-ttyS0.device. | Feb 22 15:33:15 apalis-t30 systemd[1]: Dependency failed for Serial Getty on ttyS0. | Feb 22 15:33:15 apalis-t30 systemd[1]: serial-getty@ttyS0.service: Job serial-getty@ttyS0.service/start failed with result 'dependency'. | Feb 22 15:33:15 apalis-t30 systemd[1]: dev-ttyS0.device: Job dev-ttyS0.device/start failed with result 'timeout'. | Feb 22 15:33:15 apalis-t30 systemd[1]: Reached target Login Prompts. (the time has been updated between this two events, but that does not influence the issue) Using --no-reload in the service file avoids the "Reloading." message above and seems to not cause such issues anymore. Signed-off-by: Thuy Tran <thuy.tran.xh@rvc.renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
-rw-r--r--meta-rcar-gen3/recipes-devtools/run-postinsts/run-postinsts_%.bbappend5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-rcar-gen3/recipes-devtools/run-postinsts/run-postinsts_%.bbappend b/meta-rcar-gen3/recipes-devtools/run-postinsts/run-postinsts_%.bbappend
new file mode 100644
index 0000000..ed72bf2
--- /dev/null
+++ b/meta-rcar-gen3/recipes-devtools/run-postinsts/run-postinsts_%.bbappend
@@ -0,0 +1,5 @@
+# Do not reload daemon configuration
+do_install_append () {
+ sed -e 's/\disable/--no-reload \disable/' \
+ -i ${D}${systemd_unitdir}/system/run-postinsts.service
+}