aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhang Nguyen <khang.nguyen.xw@renesas.com>2019-07-11 17:16:39 +0700
committerKhang Nguyen <khang.nguyen.xw@renesas.com>2019-09-24 08:16:24 +0700
commit968e92ffdf65402dac9e54d37970f81177fc3191 (patch)
treea1957b4e27b5f16e8d76707f6aab21c6338f32b5
parent6526f842646fe43f00a0b1af32438a9fecea6f6b (diff)
rcar-gen3: mesa: Update recipe to use meson build system
This updates recipe to use meson build system. It uses the default setting for platform: -Dplatforms='wayland,x11,surfaceless' Due to the Virgl requirement issue when setting -Dplatforms='wayland' | Host machine cpu family: aarch64 | Host machine cpu: aarch64 | Target machine cpu family: aarch64 | Target machine cpu: aarch64 | Build machine cpu family: x86_64 | Build machine cpu: x86_64 | | meson.build:335:4: ERROR: Problem encountered: Virgl requires drm or surfaceless platform when using EGL Signed-off-by: Khang Nguyen <khang.nguyen.xw@renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com> Change-Id: I49f8a9eac6a16afe9918732d8236ae80341d33f8
-rw-r--r--meta-rcar-gen3/recipes-graphics/mesa/mesa-wayland.inc4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-rcar-gen3/recipes-graphics/mesa/mesa-wayland.inc b/meta-rcar-gen3/recipes-graphics/mesa/mesa-wayland.inc
index 55b8c15..ad4a0b2 100644
--- a/meta-rcar-gen3/recipes-graphics/mesa/mesa-wayland.inc
+++ b/meta-rcar-gen3/recipes-graphics/mesa/mesa-wayland.inc
@@ -1,6 +1,6 @@
# FIXME: can not override PACKAGECONFIG.
-PACKAGECONFIG[gles] = "--enable-gles1 --disable-gles2"
-PACKAGECONFIG[egl] = "--enable-egl --with-egl-platforms=wayland"
+PACKAGECONFIG[gles] = "-Dgles1=true -Dgles2=false"
+PACKAGECONFIG[egl] = "-Degl=true"
# Disable the gbm modules of mesa
PACKAGECONFIG_remove = "gbm"