aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAymeric Aillet <aymeric.aillet@iot.bzh>2019-09-20 16:40:28 +0200
committerStephane Desneux <stephane.desneux@iot.bzh>2020-05-19 18:57:37 +0000
commita9eb8fa93867b8012e0e2d520961221a2a3ffffa (patch)
tree866e19a6cdd2ad77651c11a2b5c403b5218214cd
parent4f42dc705f5bb7a7435a7e50665d55347be658bf (diff)
[Community] Optee_os recipe modification
In order to build trusted applications from the official optee sources we need files that weren't built with the current version of the recipe. This modification allow us to build trusted applications in the AGL environment. BUG-AGL: SPEC-2848 Change-Id: Ic34121428abbaf316656519f71d876abfc1f95d5 Signed-off-by: Aymeric Aillet <aymeric.aillet@iot.bzh>
-rw-r--r--meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb b/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
index 90fc18f..6725ebb 100644
--- a/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
+++ b/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
@@ -54,8 +54,10 @@ do_compile() {
oe_runmake PLATFORM=${PLATFORM} CFG_ARM64_core=y
}
-# do_install() nothing
-do_install[noexec] = "1"
+do_install() {
+ install -d ${D}/usr/share/optee
+ cp -r ${S}/out/arm-plat-${PLATFORM}/export-ta_arm64 ${D}/usr/share/optee
+}
do_deploy() {
# Create deploy folder
@@ -67,3 +69,6 @@ do_deploy() {
install -m 0644 ${S}/out/arm-plat-${PLATFORM}/core/tee.srec ${DEPLOYDIR}/tee-${MACHINE}.srec
}
addtask deploy before do_build after do_compile
+
+FILES_${PN}-staticdev += "${datadir}/optee/export-ta_arm64/lib/*.a"
+FILES_${PN}-dev += "${datadir}/optee/export-ta_arm64"