aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3-adas/recipes-devtools/yaml-cpp/yaml-cpp_git.bb
diff options
context:
space:
mode:
authorGrigory Kletsko <grigory.kletsko@cogentembedded.com>2017-06-04 00:58:21 +0300
committerGrigory Kletsko <grigory.kletsko@cogentembedded.com>2017-06-04 00:58:21 +0300
commitff1e5894854e66e075ea9272f9b87c2fc5a414c2 (patch)
tree260f309b63bbb41cf1536e00693521700af5b0cd /meta-rcar-gen3-adas/recipes-devtools/yaml-cpp/yaml-cpp_git.bb
parent61d22faa6bfb1d6d6b1bc5cfe09c3eb8312fdaa8 (diff)
[devtools] Add yaml-cpp
Diffstat (limited to 'meta-rcar-gen3-adas/recipes-devtools/yaml-cpp/yaml-cpp_git.bb')
-rw-r--r--meta-rcar-gen3-adas/recipes-devtools/yaml-cpp/yaml-cpp_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-rcar-gen3-adas/recipes-devtools/yaml-cpp/yaml-cpp_git.bb b/meta-rcar-gen3-adas/recipes-devtools/yaml-cpp/yaml-cpp_git.bb
new file mode 100644
index 0000000..9c27f81
--- /dev/null
+++ b/meta-rcar-gen3-adas/recipes-devtools/yaml-cpp/yaml-cpp_git.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "yaml-cpp is a YAML parser and emitter in C++ matching the YAML 1.2 spec"
+HOMEPAGE = "https://github.com/jbeder/yaml-cpp/"
+SECTION = "libs"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=6a8aaf0595c2efc1a9c2e0913e9c1a2c"
+
+DEPENDS = "boost"
+
+PR = "r0"
+
+S = "${WORKDIR}/git"
+
+SRC_URI = "git://github.com/jbeder/yaml-cpp.git"
+SRCREV = "bedb28fdb4fd52d97e02f6cb946cae631037089e"
+
+# pkgconfig is enough
+do_install_append() {
+ rm -r ${D}${libdir}/cmake
+}
+
+EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON"
+
+inherit cmake \ No newline at end of file