aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3-adas
diff options
context:
space:
mode:
authorAndrey Gusakov <andrey.gusakov@cogentembedded.com>2017-08-09 12:57:58 +0300
committerAndrey Gusakov <andrey.gusakov@cogentembedded.com>2017-08-09 16:40:04 +0300
commit72bf97361c5f2abf4a188fb9074bd1f764d8ef32 (patch)
treed57ffc2f3ebca1f79a36dd09481284d666e5e710 /meta-rcar-gen3-adas
parentfc79186f671f749f9f86acf8d774acafc8c7c58c (diff)
sound: fixes and improvements
PulseAudio: use one config for all boards PulseAudio: fix config files installation ofono: install ofono for HSP and HFP functionality gstreamer: install pulseaudio stuff
Diffstat (limited to 'meta-rcar-gen3-adas')
-rw-r--r--meta-rcar-gen3-adas/conf/layer.conf2
-rw-r--r--meta-rcar-gen3-adas/recipes-multimedia/pulseaudio/files/system-mch.pa86
-rw-r--r--meta-rcar-gen3-adas/recipes-multimedia/pulseaudio/files/system.pa32
-rw-r--r--meta-rcar-gen3-adas/recipes-multimedia/pulseaudio/pulseaudio_8.0.bbappend10
4 files changed, 29 insertions, 101 deletions
diff --git a/meta-rcar-gen3-adas/conf/layer.conf b/meta-rcar-gen3-adas/conf/layer.conf
index a3abc9e..765cb0e 100644
--- a/meta-rcar-gen3-adas/conf/layer.conf
+++ b/meta-rcar-gen3-adas/conf/layer.conf
@@ -45,6 +45,7 @@ IMAGE_INSTALL_append_rcar-gen3 = " \
pulseaudio-module-cli \
pulseaudio-module-remap-sink \
pulseaudio-module-remap-source \
+ gstreamer1.0-plugins-good-pulse \
"
# Radio packages
@@ -60,6 +61,7 @@ IMAGE_INSTALL_append_rcar-gen3 += " \
pulseaudio-module-bluez5-discover \
pulseaudio-module-bluetooth-discover \
pulseaudio-module-bluetooth-policy \
+ ofono \
"
DISTRO_FEATURES_remove="x11"
diff --git a/meta-rcar-gen3-adas/recipes-multimedia/pulseaudio/files/system-mch.pa b/meta-rcar-gen3-adas/recipes-multimedia/pulseaudio/files/system-mch.pa
deleted file mode 100644
index 327bb44..0000000
--- a/meta-rcar-gen3-adas/recipes-multimedia/pulseaudio/files/system-mch.pa
+++ /dev/null
@@ -1,86 +0,0 @@
-#!/usr/bin/pulseaudio -nF
-#
-# This file is part of PulseAudio.
-#
-# PulseAudio is free software; you can redistribute it and/or modify it
-# under the terms of the GNU Lesser General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version.
-#
-# PulseAudio is distributed in the hope that it will be useful, but
-# WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
-# General Public License for more details.
-#
-# You should have received a copy of the GNU Lesser General Public License
-# along with PulseAudio; if not, write to the Free Software Foundation,
-# Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA.
-
-# This startup script is used only if PulseAudio is started in system
-# mode.
-
-## use static load order to prevent pulseaudio to auto probe MOST devices
-## MOST drivers does not like how pulse probing it and crashes system
-## PCM3168A card
-load-module module-alsa-sink sink_name=pcm3168a_output device=hw:pcm3168a format=s24-32le channels=8 rate=48000 channel_map=surround-71
-load-module module-alsa-source source_name=pcm3168a_input device=hw:pcm3168a format=s24-32le channels=8 rate=48000 channel_map=surround-71
-## Onboard sound
-## use ALSA card plugin to run UCM and initial controls setup
-load-module module-alsa-card device_id=1 rate=48000 use_ucm=1 tsched=yes
-## Radio input
-load-module module-alsa-source source_name=radio device=hw:radio channels=2 rate=48000
-
-### Load several protocols
-.ifexists module-esound-protocol-unix.so
-load-module module-esound-protocol-unix
-.endif
-load-module module-native-protocol-unix auth-anonymous=1
-
-### Automatically restore the volume of streams and devices
-load-module module-stream-restore
-load-module module-device-restore
-
-### Automatically restore the default sink/source when changed by the user
-### during runtime
-### NOTE: This should be loaded as early as possible so that subsequent modules
-### that look up the default sink/source get the right value
-load-module module-default-device-restore
-
-### Automatically move streams to the default sink if the sink they are
-### connected to dies, similar for sources
-load-module module-rescue-streams
-
-### Make sure we always have a sink around, even if it is a null sink.
-load-module module-always-sink
-
-### Automatically suspend sinks/sources that become idle for too long
-# load-module module-suspend-on-idle
-
-### Enable positioned event sounds
-# load-module module-position-event-sounds
-
-### Automatically load driver modules for Bluetooth hardware
-.ifexists module-bluetooth-policy.so
-load-module module-bluetooth-policy
-.endif
-
-.ifexists module-bluetooth-discover.so
-load-module module-bluetooth-discover
-.endif
-
-### Split multichannel card output to Stereo and 5.1
-# load-module module-remap-sink sink_name=Surround51 remix=no master=pcm3168a_output channels=6 master_channel_map=front-left,front-right,rear-left,rear-right,front-center,lfe channel_map=front-left,front-right,rear-left,rear-right,front-center,lfe
-# load-module module-remap-sink sink_name=StereoOut remix=no master=pcm3168a_output channels=2 master_channel_map=side-left,side-right channel_map=front-left,front-right
-
-### Split multichannel card input to 4 x microphone/line-ins
-# load-module module-remap-source source_name=mic0 remix=no master=pcm3168a_input channels=2 master_channel_map=front-left,front-right channel_map=front-left,front-right
-# load-module module-remap-source source_name=mic1 remix=no master=pcm3168a_input channels=2 master_channel_map=rear-left,rear-right channel_map=front-left,front-right
-# load-module module-remap-source source_name=mic2 remix=no master=pcm3168a_input channels=2 master_channel_map=front-center,lfe channel_map=front-left,front-right
-# load-module module-remap-source source_name=mic3 remix=no master=pcm3168a_input channels=2 master_channel_map=side-left,side-right channel_map=front-left,front-right
-
-### Set default source and sink to multichannel soundcard
-# set-default-sink Surround51
-# set-default-source mic0
-
-set-default-sink pcm3168a_output
-set-default-source pcm3168a_input \ No newline at end of file
diff --git a/meta-rcar-gen3-adas/recipes-multimedia/pulseaudio/files/system.pa b/meta-rcar-gen3-adas/recipes-multimedia/pulseaudio/files/system.pa
index f88fc8e..3a1be43 100644
--- a/meta-rcar-gen3-adas/recipes-multimedia/pulseaudio/files/system.pa
+++ b/meta-rcar-gen3-adas/recipes-multimedia/pulseaudio/files/system.pa
@@ -19,13 +19,16 @@
# This startup script is used only if PulseAudio is started in system
# mode.
-### Automatically load driver modules depending on the hardware available
-.ifexists module-udev-detect.so
-load-module module-udev-detect
-.else
-### Use the static hardware detection module (for systems that lack udev/hal support)
-load-module module-detect
-.endif
+## use static load order to prevent pulseaudio to auto probe MOST devices
+## MOST drivers does not like how pulse probing it and crashes system
+## PCM3168A card (Kingfisher only)
+load-module module-alsa-sink sink_name=pcm3168a_output device=hw:pcm3168a format=s24-32le channels=8 rate=48000 channel_map=surround-71
+load-module module-alsa-source source_name=pcm3168a_input device=hw:pcm3168a format=s24-32le channels=8 rate=48000 channel_map=surround-71
+## Onboard sound (All R-Car 3 boards)
+## use ALSA card plugin to run UCM and initial controls setup
+load-module module-alsa-card device_id=ak4613 rate=48000 use_ucm=1 tsched=yes sink_name=ak4613_output source_name=ak4613_input
+## Radio input (Kingfisher only)
+load-module module-alsa-source source_name=radio device=hw:radio channels=2 rate=48000
### Load several protocols
.ifexists module-esound-protocol-unix.so
@@ -55,3 +58,18 @@ load-module module-always-sink
### Enable positioned event sounds
# load-module module-position-event-sounds
+
+### Automatically load driver modules for Bluetooth hardware
+.ifexists module-bluetooth-policy.so
+load-module module-bluetooth-policy
+.endif
+
+.ifexists module-bluetooth-discover.so
+load-module module-bluetooth-discover
+.endif
+
+set-default-sink ak4613_output
+set-default-source ak4613_input
+# For Kingfisher board set default source and sink to multichannel soundcard
+set-default-sink pcm3168a_output
+set-default-source pcm3168a_input
diff --git a/meta-rcar-gen3-adas/recipes-multimedia/pulseaudio/pulseaudio_8.0.bbappend b/meta-rcar-gen3-adas/recipes-multimedia/pulseaudio/pulseaudio_8.0.bbappend
index e6c1441..705c781 100644
--- a/meta-rcar-gen3-adas/recipes-multimedia/pulseaudio/pulseaudio_8.0.bbappend
+++ b/meta-rcar-gen3-adas/recipes-multimedia/pulseaudio/pulseaudio_8.0.bbappend
@@ -7,7 +7,6 @@ SRC_URI_append_rcar-gen3 = " \
file://rsnddai0ak4613h.conf \
file://hifi \
file://system.pa \
- file://system-mch.pa \
file://daemon.conf \
file://pulseaudio-bluetooth.conf \
"
@@ -17,11 +16,6 @@ inherit update-rc.d
INITSCRIPT_NAME = "pulseaudio"
INITSCRIPT_PARAMS = "defaults 30"
-PA_SYSTEM_PA = \
- '${@ "system-mch.pa" \
- if 'kingfisher' in '${DISTRO_FEATURES}' \
- else "system.pa"}'
-
do_install_append_rcar-gen3() {
install -d ${D}/etc/init.d
install -d ${D}/etc/pulse
@@ -29,7 +23,7 @@ do_install_append_rcar-gen3() {
install -m 0755 ${WORKDIR}/pulseaudio.init ${D}/etc/init.d/pulseaudio
- install -m 0644 ${WORKDIR}/${PA_SYSTEM_PA} ${D}/etc/pulse/system.pa
+ install -m 0644 ${WORKDIR}/system.pa ${D}/etc/pulse/system.pa
install -m 0644 ${WORKDIR}/daemon.conf ${D}/etc/pulse/daemon.conf
install -m 0644 ${WORKDIR}/rsnddai0ak4613h.conf ${D}${datadir}/alsa/ucm/rsnddai0ak4613h/rsnddai0ak4613h.conf
@@ -39,7 +33,7 @@ do_install_append_rcar-gen3() {
install -m 644 ${WORKDIR}/pulseaudio-bluetooth.conf ${D}/${sysconfdir}/dbus-1/system.d/
}
-FILES_${PN} += " \
+FILES_${PN}-server += " \
${datadir}/alsa/ucm \
${datadir}/dbus-1/ \
"