aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3-adas
diff options
context:
space:
mode:
authorAndrey Gusakov <andrey.gusakov@cogentembedded.com>2017-08-01 18:07:27 +0300
committerAndrey Gusakov <andrey.gusakov@cogentembedded.com>2017-08-01 18:08:09 +0300
commitfe9f6409ddcf2ab13e190c0bd6b69332e25729bf (patch)
tree2e5143af63f3754e3f208d85513d31f2a873f84b /meta-rcar-gen3-adas
parentfaf087de91b0f28e244b004be1ac20fad99be26b (diff)
Kingfisher: fixes for bluetooth audio
Diffstat (limited to 'meta-rcar-gen3-adas')
-rw-r--r--meta-rcar-gen3-adas/recipes-kernel/linux/linux-renesas/ulcb.cfg3
-rw-r--r--meta-rcar-gen3-adas/recipes-multimedia/pulseaudio/files/pulseaudio-bluetooth.conf7
-rw-r--r--meta-rcar-gen3-adas/recipes-multimedia/pulseaudio/files/system-mch.pa17
-rw-r--r--meta-rcar-gen3-adas/recipes-multimedia/pulseaudio/pulseaudio_8.0.bbappend7
4 files changed, 28 insertions, 6 deletions
diff --git a/meta-rcar-gen3-adas/recipes-kernel/linux/linux-renesas/ulcb.cfg b/meta-rcar-gen3-adas/recipes-kernel/linux/linux-renesas/ulcb.cfg
index 63d9645..a8befb9 100644
--- a/meta-rcar-gen3-adas/recipes-kernel/linux/linux-renesas/ulcb.cfg
+++ b/meta-rcar-gen3-adas/recipes-kernel/linux/linux-renesas/ulcb.cfg
@@ -39,6 +39,9 @@ CONFIG_USB_ACM=y
CONFIG_VIDEO_RENESAS_IMR=y
CONFIG_VIRTIO_RCAR_PCIE=y
CONFIG_BT=y
+CONFIG_BT_BNEP=m
+CONFIG_BT_RFCOMM=m
+CONFIG_BT_HIDP=m
CONFIG_TI_ST=m
CONFIG_BT_WILINK=m
CONFIG_WEXT_CORE=y
diff --git a/meta-rcar-gen3-adas/recipes-multimedia/pulseaudio/files/pulseaudio-bluetooth.conf b/meta-rcar-gen3-adas/recipes-multimedia/pulseaudio/files/pulseaudio-bluetooth.conf
new file mode 100644
index 0000000..925b9b1
--- /dev/null
+++ b/meta-rcar-gen3-adas/recipes-multimedia/pulseaudio/files/pulseaudio-bluetooth.conf
@@ -0,0 +1,7 @@
+<busconfig>
+
+ <policy user="pulse">
+ <allow send_destination="org.bluez"/>
+ </policy>
+
+</busconfig>
diff --git a/meta-rcar-gen3-adas/recipes-multimedia/pulseaudio/files/system-mch.pa b/meta-rcar-gen3-adas/recipes-multimedia/pulseaudio/files/system-mch.pa
index 52648d2..327bb44 100644
--- a/meta-rcar-gen3-adas/recipes-multimedia/pulseaudio/files/system-mch.pa
+++ b/meta-rcar-gen3-adas/recipes-multimedia/pulseaudio/files/system-mch.pa
@@ -59,15 +59,24 @@ load-module module-always-sink
### Enable positioned event sounds
# load-module module-position-event-sounds
-### Split multichannel card output to Bluetooth PCM and 5.1
+### Automatically load driver modules for Bluetooth hardware
+.ifexists module-bluetooth-policy.so
+load-module module-bluetooth-policy
+.endif
+
+.ifexists module-bluetooth-discover.so
+load-module module-bluetooth-discover
+.endif
+
+### Split multichannel card output to Stereo and 5.1
# load-module module-remap-sink sink_name=Surround51 remix=no master=pcm3168a_output channels=6 master_channel_map=front-left,front-right,rear-left,rear-right,front-center,lfe channel_map=front-left,front-right,rear-left,rear-right,front-center,lfe
-# load-module module-remap-sink sink_name=BluetoothPCM_output remix=no master=pcm3168a_output channels=2 master_channel_map=side-left,side-right channel_map=front-left,front-right
+# load-module module-remap-sink sink_name=StereoOut remix=no master=pcm3168a_output channels=2 master_channel_map=side-left,side-right channel_map=front-left,front-right
-### Split multichannel card input to 3 x microphone/line-ins and Bluetooth PCM input
+### Split multichannel card input to 4 x microphone/line-ins
# load-module module-remap-source source_name=mic0 remix=no master=pcm3168a_input channels=2 master_channel_map=front-left,front-right channel_map=front-left,front-right
# load-module module-remap-source source_name=mic1 remix=no master=pcm3168a_input channels=2 master_channel_map=rear-left,rear-right channel_map=front-left,front-right
# load-module module-remap-source source_name=mic2 remix=no master=pcm3168a_input channels=2 master_channel_map=front-center,lfe channel_map=front-left,front-right
-# load-module module-remap-source source_name=BluetoothPCM_inout remix=no master=pcm3168a_input channels=2 master_channel_map=side-left,side-right channel_map=front-left,front-right
+# load-module module-remap-source source_name=mic3 remix=no master=pcm3168a_input channels=2 master_channel_map=side-left,side-right channel_map=front-left,front-right
### Set default source and sink to multichannel soundcard
# set-default-sink Surround51
diff --git a/meta-rcar-gen3-adas/recipes-multimedia/pulseaudio/pulseaudio_8.0.bbappend b/meta-rcar-gen3-adas/recipes-multimedia/pulseaudio/pulseaudio_8.0.bbappend
index 51977db..3f26f59 100644
--- a/meta-rcar-gen3-adas/recipes-multimedia/pulseaudio/pulseaudio_8.0.bbappend
+++ b/meta-rcar-gen3-adas/recipes-multimedia/pulseaudio/pulseaudio_8.0.bbappend
@@ -9,6 +9,7 @@ SRC_URI_append_rcar-gen3 = " \
file://system.pa \
file://system-mch.pa \
file://daemon.conf \
+ file://pulseaudio-bluetooth.conf \
"
inherit update-rc.d
@@ -33,10 +34,12 @@ do_install_append_rcar-gen3() {
install -m 0644 ${WORKDIR}/rsnddai0ak4613h.conf ${D}${datadir}/alsa/ucm/rsnddai0ak4613h/rsnddai0ak4613h.conf
install -m 0644 ${WORKDIR}/hifi ${D}${datadir}/alsa/ucm/rsnddai0ak4613h/hifi
-
+
+ install -d ${D}/${sysconfdir}/dbus-1/system.d
+ install -m 644 ${WORKDIR}/pulseaudio-bluetooth.conf ${D}/${sysconfdir}/dbus-1/
}
FILES_${PN} += " \
${datadir}/alsa/ucm \
+ ${datadir}/dbus-1/ \
"
-