aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-bsp/optee/optee-os/0001-plat-rcar-fix-MMU-configuration-of-shared-memory.patch
diff options
context:
space:
mode:
authorKhang Nguyen <khang.nguyen.xw@renesas.com>2018-10-28 20:59:49 -0400
committerKhang Nguyen <khang.nguyen.xv@renesas.com>2018-10-29 13:41:32 +0700
commit9f7ba089e8a0cc49c8114954c1182fedf341540e (patch)
treefdb6933ce69b8bf7425640d3bf3d8e63ed534f56 /meta-rcar-gen3/recipes-bsp/optee/optee-os/0001-plat-rcar-fix-MMU-configuration-of-shared-memory.patch
parente5a8cfdc84a83544f281f33fcbe3ce15bb0ab119 (diff)
rcar-gen3: IPL: Upgrade IPL version according to BSP v3.8.0
This commit updates IPL and Secure Monitor to Rev1.0.23 rev2 for the following changes: [IPL] - plat: rcar: BL2: Correct MMU configuration. - plat: rcar: Fix suspicious line in platform.mk. - Change the definition value of BL2_LIMIT to end of System RAM. - Update IPL boot message. - Version up the base version to v1.5 of arm-trusted-firmware. - Update DDR setting (rev.0.34). - Modify the alignment of l2_tzram_layout to CACHE_WRITEBACK_GRANULE. - Update H3 Ver.3.0 QoS setting rev.0.08. - Update M3N Ver.1.1 QoS setting rev.0.07. - Update E3 Ver.1.0 QoS setting rev.0.03. - Fix the system WDT detection log is not output when D-Cache is enabled. - Change the timer counter of micro_wait to the Generic Timer. - Fix to log the timestamp at beginning of line. - Change the timer counter for processing time measurement to the Generic Timer. - Modify the DDR log output of IPL boot message. [Secure Monitor] - Version up the base version of arm-trusted-firmware. https://github.com/ARM-software/arm-trusted-firmware Commit ID ed8112606c54d85781fc8429160883d6310ece32 [Tag: v1.5] - Backport the workaround for CVE-2018-3639. Update optee_os Rev1.0.16 rev2 - Fix a contxt size allocated by OP-TEE OS with HW engine. - Fix to exclusive control in ECDSA operation used by HW engine. - Fix to set the initial value for a parameter in TEE_AEInit. - Fix to clear the read cache of standalone_fs_create. Signed-off-by: Khang Nguyen <khang.nguyen.xw@renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
Diffstat (limited to 'meta-rcar-gen3/recipes-bsp/optee/optee-os/0001-plat-rcar-fix-MMU-configuration-of-shared-memory.patch')
-rw-r--r--meta-rcar-gen3/recipes-bsp/optee/optee-os/0001-plat-rcar-fix-MMU-configuration-of-shared-memory.patch46
1 files changed, 0 insertions, 46 deletions
diff --git a/meta-rcar-gen3/recipes-bsp/optee/optee-os/0001-plat-rcar-fix-MMU-configuration-of-shared-memory.patch b/meta-rcar-gen3/recipes-bsp/optee/optee-os/0001-plat-rcar-fix-MMU-configuration-of-shared-memory.patch
deleted file mode 100644
index f1d0739..0000000
--- a/meta-rcar-gen3/recipes-bsp/optee/optee-os/0001-plat-rcar-fix-MMU-configuration-of-shared-memory.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From 67e2c72b2a20c859bc5cb7a2ea91b9bd9732c3a4 Mon Sep 17 00:00:00 2001
-From: Jun Miyauchi <jun.miyauchi.sr@hitachi.com>
-Date: Fri, 26 Oct 2018 10:39:08 +0900
-Subject: [PATCH] plat-rcar: fix MMU configuration of shared memory
-
-Signed-off-by: Jun Miyauchi <jun.miyauchi.sr@hitachi.com>
----
- core/arch/arm/plat-rcar/platform_config.h | 12 +++++-------
- 1 file changed, 5 insertions(+), 7 deletions(-)
-
-diff --git a/core/arch/arm/plat-rcar/platform_config.h b/core/arch/arm/plat-rcar/platform_config.h
-index ebc12557..3c8fd8af 100644
---- a/core/arch/arm/plat-rcar/platform_config.h
-+++ b/core/arch/arm/plat-rcar/platform_config.h
-@@ -48,11 +48,11 @@
- #define CFG_TA_RAM_SIZE (0x01E00000U) /* TA RAM size */
-
- #define CFG_SHMEM_START (0x47E00000U) /* Share Memory address */
--#define CFG_SHMEM_SIZE (0x00200000U) /* Share Memory size */
-- /* plus OP-TEE Log Area NS size(1MB) */
-+#define CFG_SHMEM_SIZE (0x00100000U) /* Share Memory size */
-
- #define OPTEE_LOG_BASE (0x46400000U) /* OP-TEE Log Area address */
- #define OPTEE_LOG_NS_BASE (0x47FEC000U) /* OP-TEE Log Area NS address */
-+#define OPTEE_LOG_NS_SIZE (0x00014000U) /* OP-TEE Log Area NS size */
-
- #define TA_VERIFICATION_BASE (0x46200000U) /* TA area for verification */
- #define TA_VERIFICATION_SIZE (0x00100000U) /* TA verification size */
-@@ -121,11 +121,9 @@
- #define MEMORY1_EXEC false
-
- /* LOG Area for Normal World */
--/* Map with CFG_SHMEM_START
--#define MEMORY2_BASE ROUNDDOWN(OPTEE_LOG_NS_BASE, MEM_SECTION_SIZE)
--*/
--#define MEMORY2_SIZE (MEM_SECTION_SIZE)
--#define MEMORY2_TYPE MEM_AREA_IO_NSEC
-+#define MEMORY2_BASE (OPTEE_LOG_NS_BASE)
-+#define MEMORY2_SIZE (OPTEE_LOG_NS_SIZE)
-+#define MEMORY2_TYPE MEM_AREA_RAM_NSEC
- #define MEMORY2_SECURE false
- #define MEMORY2_CACHED false
- #define MEMORY2_DEVICE false
---
-2.14.1
-