aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
diff options
context:
space:
mode:
authorKhang Nguyen <khang.nguyen.xw@renesas.com>2020-05-04 18:07:55 +0900
committerKhang Nguyen <khang.nguyen.xw@renesas.com>2020-05-04 18:17:34 +0900
commit8999dcbafa3d1cb5349e95caf33485e8d7baf57a (patch)
tree3b107bf10c04850d77f9b7ed2c48f6caac00de6e /meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
parent008d6ed05548f4f38af831fc0b4b778eec512d9a (diff)
rcar-gen3: Switch to python3
This updates recipes to use Python3 instead of Python2 which is deprecated in Yocto. Signed-off-by: Khang Nguyen <khang.nguyen.xw@renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com> Change-Id: Id2594e5bb0e0003b22af8d183bef340587a9c1aa
Diffstat (limited to 'meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb')
-rw-r--r--meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb b/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
index 553174b..90fc18f 100644
--- a/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
+++ b/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
@@ -8,7 +8,7 @@ LIC_FILES_CHKSUM = " \
PACKAGE_ARCH = "${MACHINE_ARCH}"
-inherit deploy pythonnative
+inherit deploy python3native
PV = "3.1.0+renesas+git${SRCPV}"
@@ -24,12 +24,13 @@ SRC_URI = " \
SRC_URI_append = " \
file://0001-core-define-syscall_t-as-void-void.patch \
+ file://0001-scripts-update-scripts-to-use-python3.patch \
"
COMPATIBLE_MACHINE = "(salvator-x|h3ulcb|m3ulcb|m3nulcb|ebisu)"
PLATFORM = "rcar"
-DEPENDS = "python-pycrypto-native"
+DEPENDS = "python3-pycrypto-native"
export CROSS_COMPILE64="${TARGET_PREFIX}"