aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
diff options
context:
space:
mode:
authorKhang Nguyen <khang.nguyen.xw@renesas.com>2018-09-03 23:50:35 -0400
committerDuy Dang <duy.dang.yw@rvc.renesas.com>2018-10-19 09:25:15 +0700
commite0272de38ce87f2a9b0e2bac4162d87d11735992 (patch)
tree7e9c97eda270f6991e813742313cf8e9d6220b2a /meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
parentfea65609a564a85b508a1cb29bbf97c7c9b5bf5f (diff)
rcar-gen3: IPL: Update IPL to the latest version
This commit updates IPL/Secure Monitor for the following changes: Update IPL and Secure Monitor Rev1.0.22 [IPL] - Update CPG setting. - Add support Ebisu-4D board. - Change the timing to invalidate of instruction cache. - Fixed a bug in the exception handler. - Update DDR setting for E3. [Secure Monitor] - Add the wait processing that is placed in the system RAM area for Suspend To RAM. Update optee_os Rev1.0.15 - Fix the polling process of the HyperFlash driver waiting for HW completion. - Fix incorrect memory access in RSA processing using a provider for a HW engine driver. - Fix a conditional branch in a mutex_destroy function. Signed-off-by: Khang Nguyen <khang.nguyen.xw@renesas.com> Signed-off-by: Duy Dang <duy.dang.yw@rvc.renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
Diffstat (limited to 'meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb')
-rw-r--r--meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb12
1 files changed, 10 insertions, 2 deletions
diff --git a/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb b/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
index 30f430e..765e24d 100644
--- a/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
+++ b/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
@@ -13,8 +13,8 @@ inherit deploy pythonnative
PV = "3.1.0+renesas+git${SRCPV}"
BRANCH = "rcar_gen3"
-SRCREV_renesas = "5524832ca895973a372223a6bff9cc3fc7df4b15"
-SRCREV_officialgit = "0ab9388c0d553a6bb5ae04e41b38ba40cf0474bf"
+SRCREV_renesas = "459c612224e123658a2ad29a91a3d186342d24a9"
+SRCREV_officialgit = "e77020396508fc086d7a4d6137388b116e4a662f"
SRCREV_FORMAT = "renesas_officialgit"
SRC_URI = " \
@@ -22,6 +22,12 @@ SRC_URI = " \
git://github.com/OP-TEE/optee_os.git;branch=master;name=officialgit;destsuffix=git_official \
"
+# Patch for Yv3.9.0.1
+SRC_URI_append = " \
+ file://0001-OPTEE_PROVIDER-188185-Fix-a-contxt-size-allocated-by.patch \
+ file://0002-OPTEE_PROVIDER-188122-Fix-to-exclusive-control-for-R.patch \
+"
+
COMPATIBLE_MACHINE = "(salvator-x|h3ulcb|m3ulcb|ebisu)"
PLATFORM = "rcar"
@@ -43,6 +49,8 @@ S = "${WORKDIR}/git"
EXTRA_OEMAKE = "-e MAKEFLAGS="
do_configure() {
+ git -C ${WORKDIR}/git_official checkout -B official 3.1.0
+ git -C ${WORKDIR}/git_official cherry-pick ${SRCREV_officialgit}
cp -rn ${WORKDIR}/git_official/core/lib/libtomcrypt ${B}/core/lib/.
}