aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-bsp
diff options
context:
space:
mode:
authorThuy Tran <thuy.tran.xh@renesas.com>2018-09-21 13:16:22 +0700
committerKhang Nguyen <khang.nguyen.xv@renesas.com>2018-10-29 13:41:32 +0700
commit62bb4d6f261e51db60269ec97c2670a82b616b2c (patch)
tree4ecffdb234cc3d5b44d89da5047868a744d9e857 /meta-rcar-gen3/recipes-bsp
parent9f7ba089e8a0cc49c8114954c1182fedf341540e (diff)
rcar-gen3: IPL: Support generating all variants of IPL binaries
This commit provides the capability to generate IPL binaries for H3/H3ULCB/E3 build variants at the same time. - For H3 SiP - *.srec: use for H3 SiP DDR 4GiB (1GiB x 4ch) - *-4x2g.srec: use for H3 SiP DDR 8GiB (2GiB x 4ch) - *-2x2g.srec: use for H3 SiP DDR 4GiB (2GiB x 2ch) - For H3ULCB SiP - *.srec: use for H3ULCB SiP DDR 4GiB (1GiB x 4ch) - *-4x2g.srec: use for H3ULCB SiP DDR 8GiB (2GiB x 4ch) - For E3 SiP - *.srec: use for E3 SiP DDR 1GiB - *-4d.srec: use for E3 SiP DDR 2GiB Signed-off-by: Thuy Tran <thuy.tran.xh@renesas.com> Signed-off-by: Khang Nguyen <khang.nguyen.xw@renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
Diffstat (limited to 'meta-rcar-gen3/recipes-bsp')
-rw-r--r--meta-rcar-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-rcar-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bb b/meta-rcar-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bb
index 096d25d..1456ff7 100644
--- a/meta-rcar-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bb
+++ b/meta-rcar-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bb
@@ -19,9 +19,8 @@ PV = "v1.5+renesas+git${SRCPV}"
COMPATIBLE_MACHINE = "(salvator-x|ulcb|ebisu)"
PLATFORM = "rcar"
-H3_IPL_OPTION = "${@get_ipl_config_opt(d)}"
ATFW_OPT_LOSSY = "${@base_conditional("USE_MULTIMEDIA", "1", "RCAR_LOSSY_ENABLE=1", "", d)}"
-ATFW_OPT_r8a7795 = "LSI=H3 ${H3_IPL_OPTION} ${ATFW_OPT_LOSSY}"
+ATFW_OPT_r8a7795 = "LSI=H3 RCAR_DRAM_SPLIT=1 RCAR_DRAM_LPDDR4_MEMCONF=0 ${ATFW_OPT_LOSSY}"
ATFW_OPT_r8a7796 = "LSI=M3 RCAR_DRAM_SPLIT=2 ${ATFW_OPT_LOSSY}"
ATFW_OPT_r8a77965 = "LSI=M3N ${ATFW_OPT_LOSSY}"
ATFW_OPT_r8a77990 = "LSI=E3 RCAR_SA0_SIZE=0 RCAR_AVS_SETTING_ENABLE=0 RCAR_DRAM_DDR3L_MEMCONF=0 RCAR_DRAM_DDR3L_MEMDUAL=0"
@@ -37,6 +36,7 @@ AS[unexport] = "1"
LD[unexport] = "1"
do_compile() {
+ oe_runmake distclean
oe_runmake bl2 bl31 dummytool PLAT=${PLATFORM} ${ATFW_OPT}
}