aboutsummaryrefslogtreecommitdiffstats
path: root/meta-rcar-gen3/recipes-bsp
diff options
context:
space:
mode:
authorThuy Tran <thuy.tran.xh@rvc.renesas.com>2017-12-23 12:00:22 +0700
committerThuy Tran <thuy.tran.xh@rvc.renesas.com>2018-01-30 10:00:50 +0700
commitc7bf6dd5e219a9066f31debf177e23abe28f13a5 (patch)
tree7b44b0889e99cc46114acd0d63ce965116d8aa20 /meta-rcar-gen3/recipes-bsp
parentca80cc5603eb810c8f47694f553b13ff79060ff1 (diff)
rcar-gen3: IPL: Update IPL version according to BSP v3.6.0
This commit changes following contents: - Update IPL and Secure Monitor Rev1.0.18 rev2 - Update optee_os Rev1.0.11 rev2 Signed-off-by: Thuy Tran <thuy.tran.xh@rvc.renesas.com> Signed-off-by: Takamitsu Honda <takamitsu.honda.pv@renesas.com>
Diffstat (limited to 'meta-rcar-gen3/recipes-bsp')
-rw-r--r--meta-rcar-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bb6
-rw-r--r--meta-rcar-gen3/recipes-bsp/optee/optee-client/0001-Add-LDFLAGS-option.patch39
-rw-r--r--meta-rcar-gen3/recipes-bsp/optee/optee-client/optee.service2
-rw-r--r--meta-rcar-gen3/recipes-bsp/optee/optee-client_git.bb5
-rw-r--r--meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb8
5 files changed, 48 insertions, 12 deletions
diff --git a/meta-rcar-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bb b/meta-rcar-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bb
index 504f0e4..a088c2f 100644
--- a/meta-rcar-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bb
+++ b/meta-rcar-gen3/recipes-bsp/arm-trusted-firmware/arm-trusted-firmware_git.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "ARM Trusted Firmware"
LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://license.md;md5=829bdeb34c1d9044f393d5a16c068371"
+LIC_FILES_CHKSUM = "file://license.rst;md5=33065335ea03d977d0569f270b39603e"
PACKAGE_ARCH = "${MACHINE_ARCH}"
@@ -12,9 +12,9 @@ S = "${WORKDIR}/git"
BRANCH = "rcar_gen3"
SRC_URI = "git://github.com/renesas-rcar/arm-trusted-firmware.git;branch=${BRANCH}"
-SRCREV = "b15fefa8c485cb955170cb9b4c44386f82df14a9"
+SRCREV = "b01e6aa3f22eaf4a769dc0be29ef69eb89911b60"
-PV = "v1.3+renesas+git${SRCPV}"
+PV = "v1.4+renesas+git${SRCPV}"
COMPATIBLE_MACHINE = "(salvator-x|ulcb)"
PLATFORM = "rcar"
diff --git a/meta-rcar-gen3/recipes-bsp/optee/optee-client/0001-Add-LDFLAGS-option.patch b/meta-rcar-gen3/recipes-bsp/optee/optee-client/0001-Add-LDFLAGS-option.patch
new file mode 100644
index 0000000..94d25ff
--- /dev/null
+++ b/meta-rcar-gen3/recipes-bsp/optee/optee-client/0001-Add-LDFLAGS-option.patch
@@ -0,0 +1,39 @@
+From 2035e9a30a235204b3d96ec369ad601dfd93579d Mon Sep 17 00:00:00 2001
+From: Jun Miyauchi <jun.miyauchi.sr@hitachi.com>
+Date: Fri, 22 Dec 2017 09:13:57 +0900
+Subject: [PATCH] Add LDFLAGS option
+
+---
+ libteec/Makefile | 2 +-
+ tee-supplicant/Makefile | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/libteec/Makefile b/libteec/Makefile
+index 568a2cd..a9cca19 100644
+--- a/libteec/Makefile
++++ b/libteec/Makefile
+@@ -45,7 +45,7 @@ libteec: $(TEEC_LIBRARY)
+
+ $(TEEC_LIBRARY): $(TEEC_OBJS)
+ @echo " LINK $@"
+- $(VPREFIX)$(CC) -shared -Wl,-soname,$(LIB_MAJ_MIN) $(TEEC_LFLAGS) -o $@ $+
++ $(VPREFIX)$(CC) $(LDFLAGS) -shared -Wl,-soname,$(LIB_MAJ_MIN) $(TEEC_LFLAGS) -o $@ $+
+ @echo ""
+
+ $(TEEC_OBJ_DIR)/%.o: ${TEEC_SRC_DIR}/%.c
+diff --git a/tee-supplicant/Makefile b/tee-supplicant/Makefile
+index 737d39a..98e7408 100644
+--- a/tee-supplicant/Makefile
++++ b/tee-supplicant/Makefile
+@@ -69,7 +69,7 @@ tee-supplicant: $(TEES_FILE)
+
+ $(TEES_FILE): $(TEES_OBJS)
+ @echo " LINK $@"
+- $(VPREFIX)$(CC) -o $@ $+ $(TEES_LDFLAGS)
++ $(VPREFIX)$(CC) $(LDFLAGS) -o $@ $+ $(TEES_LDFLAGS)
+ @echo ""
+
+ $(TEES_OBJ_DIR)/%.o: $(TEES_SRC_DIR)/%.c
+--
+2.14.1.windows.1
+
diff --git a/meta-rcar-gen3/recipes-bsp/optee/optee-client/optee.service b/meta-rcar-gen3/recipes-bsp/optee/optee-client/optee.service
index 4396f9f..37fc4f7 100644
--- a/meta-rcar-gen3/recipes-bsp/optee/optee-client/optee.service
+++ b/meta-rcar-gen3/recipes-bsp/optee/optee-client/optee.service
@@ -2,10 +2,8 @@
Description=optee services
[Service]
-ExecStartPre=/sbin/modprobe -q optee_armtz
ExecStart=/usr/bin/tee-supplicant
ExecStop=/usr/bin/killall -s KILL tee-supplicant
-ExecStopPost=/sbin/modprobe -r optee_armtz
[Install]
WantedBy=multi-user.target
diff --git a/meta-rcar-gen3/recipes-bsp/optee/optee-client_git.bb b/meta-rcar-gen3/recipes-bsp/optee/optee-client_git.bb
index 9efbfb5..454f82b 100644
--- a/meta-rcar-gen3/recipes-bsp/optee/optee-client_git.bb
+++ b/meta-rcar-gen3/recipes-bsp/optee/optee-client_git.bb
@@ -3,12 +3,13 @@ LICENSE = "BSD-2-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=69663ab153298557a59c67a60a743e5b"
PR = "r0"
-PV = "1.1.0+renesas+git${SRCPV}"
+PV = "2.6.0+renesas+git${SRCPV}"
BRANCH = "master"
SRC_URI = "git://github.com/OP-TEE/optee_client.git;branch=${BRANCH}"
-SRCREV = "db9c64d45818d146200297eaaedbd421a8b59e3a"
+SRCREV = "73b4e490a8ed0b4a7714818e80998b9d8a7da958"
SRC_URI += " \
+ file://0001-Add-LDFLAGS-option.patch \
file://optee.service \
"
diff --git a/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb b/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
index 276c8ca..55eab8e 100644
--- a/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
+++ b/meta-rcar-gen3/recipes-bsp/optee/optee-os_git.bb
@@ -3,20 +3,18 @@ DESCRIPTION = "OP-TEE OS"
LICENSE = "BSD-2-Clause & BSD-3-Clause"
LIC_FILES_CHKSUM = " \
file://LICENSE;md5=69663ab153298557a59c67a60a743e5b \
- file://lib/libpng/LICENSE;md5=06a1b6fde6d93170bb72201c8000bf3d \
file://${WORKDIR}/git_official/LICENSE;md5=69663ab153298557a59c67a60a743e5b \
- file://${WORKDIR}/git_official/lib/libpng/LICENSE;md5=06a1b6fde6d93170bb72201c8000bf3d \
"
PACKAGE_ARCH = "${MACHINE_ARCH}"
inherit deploy pythonnative
-PV = "2.2.0+renesas+git${SRCPV}"
+PV = "2.6.0+renesas+git${SRCPV}"
BRANCH = "rcar_gen3"
-SRCREV_renesas = "9f55b367da9f5ba6966eb75383d2f6ff472a473f"
-SRCREV_officialgit = "c0c5d399d81a0669f5c8e3bcb20039d65649a78d"
+SRCREV_renesas = "d1e9802d537b9fe8d1b7cace09254049b3dfca3f"
+SRCREV_officialgit = "6d57389f9eec0c213da917e35861a8eca4b205b3"
SRCREV_FORMAT = "renesas_officialgit"
SRC_URI = " \